Results 1 to 8 of 8

Thread: Locked up, now have some issues!!

  1. #1

    Default Locked up, now have some issues!!

    I was listening to amarok when my system locked up... I rebooted, and now I am having trouble. First, MP3's wont play. I tried to go to the repo and reload xine, etc, but now font errors keep popping up, and when I try to install anything from the repos it fails with;

    Subprocess failed. Error: RPM failed: error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "" records from Provideversion index

    and repeats

    any help?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Locked up, now have some issues!!

    From a terminal post result of

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Locked up, now have some issues!!

    Thanks, I rebuilt the rpm database, (rpm --rebuilddb)which allowed me to re-install xine.. but MP3's still don't work..

    here's the output of the zypper command

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-----------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | KDE_Community | KDE Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    2 | KDE_Core | KDE Core | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2 |
    3 | KDE_Playground | KDE Playground | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.2 |
    4 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.2/ |
    5 | Nvidia | Nvidia | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.2/ |
    6 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    7 | google | google | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/x86_64 |
    8 | http-download.opensuse.org-dc0f15c1 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    9 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
    10 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/factory |
    11 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    12 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    13 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    14 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    15 | vlc_ | vlc | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.2/

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Locked up, now have some issues!!

    You need to remove 15, 10, 4

    Change the priority of number 6 Packman to 90

    You should follow this, obviously you didn't
    Multi-media and Restricted Format Installation Guide - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Locked up, now have some issues!!

    well, it was all working fine since I installed a few days ago.
    then the crash..
    then I clicked the "one click" media thing on the page you just linked thinking that would solve my issue by reloading the media stuff..
    But, then I got the errors.

    So, I've removed those repos that the "one click" thing added (those one clicks are dangerous!) I've unconditionally updated anything w/ the words xine and MP3 in it, and mp3's still don't work...

    I'm concerned about what all got damaged in the crash.. is there any way to tell? And what is the procedure for repairing it now that there is obviously some damage?

  6. #6

    Default Re: Locked up, now have some issues!!

    Ok, I unconditionally updated everything from packman, and MP3's work again.

    Should I be worried about anything else being damaged? I guess I won't and just fix any issues I notice as I use my system.

    Thanks for your help!!

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Locked up, now have some issues!!

    You should be OK.
    Don't use OneClicks

    Look carefully at the Mutli-Media guide I posted. Check your priorities on Packman
    Take note of the new feature to Upgrade packages to the version in the selected repo
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    I'm off to bed
    But if you want to post your repo info again. I'll look it over in about 5-6 hrs from now
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Locked up, now have some issues!!

    Hahah, no I think I'm good now.
    My repos are back to what they were yesterday (just KDE, SUSE, and Packman), I'm playing music, tested the few other things I use on a daily basis and they are all working fine.

    No more one clicks for me! I've seen enough posts from other people who's repo's are all messed up from them.

    Thanks! SUSE rocks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •