Results 1 to 7 of 7

Thread: Enable Desktop effects kills Suse 11.2

  1. #1

    Default Enable Desktop effects kills Suse 11.2

    Greetings All,

    I installed Suse 11.2 with the default KDE4 desktop.

    I selected Configure Desktop and clicked on the
    Enable desktop Effects. At that point, the system froze.
    I can no longer get back to the desktop. After reseting the
    machine (and fsck'ing all the partitions) I am faced with a green
    OpenSUSE screen and a half completed progress bar. All that can be done at this point is to reset the computer again.

    Can this be fixed without a reinstall?

    Doesn't make me feel good about KDE 4 (I want my 3.5 back!)


    Rich

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Enable Desktop effects kills Suse 11.2

    Rich,

    I've been using KDE4 for quite a while now and I can assure you it works fine.

    Where exactly do you see the progress bar? Is it still during the boot process or when KDE4 tries to start?

    For starters, reset the machine and on the kernel selection screen at the very start, add an option "3". This should bring you at least to a command line login. Does this work?

    Uwe

  3. #3

    Default Re: Enable Desktop effects kills Suse 11.2

    Quote Originally Posted by buckesfeld View Post
    Rich,

    I've been using KDE4 for quite a while now and I can assure you it works fine.

    Where exactly do you see the progress bar? Is it still during the boot process or when KDE4 tries to start?

    For starters, reset the machine and on the kernel selection screen at the very start, add an option "3". This should bring you at least to a command line login. Does this work?

    Uwe
    The progress bar is when KDE is being started. Boot process is OK (I can start in runlevel 3 with no problem).

    Somehow, I managed to "fix" this by selecting the failsafe
    boot from the Grub menu. Not sure what happened, but I am very leery of attempting any desktop customization again....

    I'm not comfortable with KDE4, and this initial glitch makes me even less so....

    Rich

  4. #4
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: Enable Desktop effects kills Suse 11.2

    What video driver are you using? If you don't have 3D working, it will cause it to lock up like this when you select the desktop effects, because it can't make them work.

    Yes, booting in FailSafe is the easiest way to get back in to change it back.

  5. #5

    Default Re: Enable Desktop effects kills Suse 11.2

    Quote Originally Posted by Wilson_Phillips View Post
    What video driver are you using? If you don't have 3D working, it will cause it to lock up like this when you select the desktop effects, because it can't make them work.

    Yes, booting in FailSafe is the easiest way to get back in to change it back.

    I'm using whatever video driver SUSE installed. I have a
    ATI Radeon HD 4350 card.

    Also the video configuration icon appears to be gone from the YAST panel. I'm assuming that issuing sax2 from the command line is now the only way to configure the display?

    Rich

  6. #6
    Join Date
    Feb 2009
    Location
    Burgas, Bulgaria
    Posts
    148

    Default Re: Enable Desktop effects kills Suse 11.2

    Hi, i have the same video card and had this problem when trying the open source driver The fix is going to ATI's site and install the proprietary driver. Be sure to install the needed dependencies or you'll end up with broken Kwin.

  7. #7
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Enable Desktop effects kills Suse 11.2

    * richardrosa wrote, On 11/14/2009 03:16 PM:
    > Also the video configuration icon appears to be gone from the YAST
    > panel. I'm assuming that issuing sax2 from the command line is now the
    > only way to configure the display?


    It should work without xorg.conf. AFAIK it only comes into play when you install third party drivers.
    You can run sax2 in order to generate an xorg.conf.

    Check the release notes.

    Uwe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •