Page 3 of 14 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 133

Thread: OpenSuse 11.2 Black Screen

  1. #21

    Default Re: OpenSuse 11.2 Black Screen

    Hi everybody.
    I think I'm having similiar problem. I tried all 6 versions both DVD and CD, 32 and 64, KDE and Gnome on my laptop.. It beginns with a nice meny but when I clik to start the live cd I just get a blank black screen. Nothing happens. I installed it using the DVD, after reboot nothing happened, just a black screen. I tried every possible alternative on the boot meny with the live CDs. Later I found out that the install even erased all my personal files. :-(
    Anyone who can guid me to make it work?
    My laptop specs are Intel Pentium Dual Core 1.6 Gh, 2 Gb RAM, ATI X1250 Graphics. On my desktop, has Nvidia graphics it worked without any problem, but I'll stik with 11.1 for now cause I still can't give up on KDE 3.5 :-D
    Thanks for all help.

  2. #22
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,435
    Blog Entries
    1

    Default Re: OpenSuse 11.2 Black Screen

    Not sure if you're asking for help, or simply reporting your experience. In any case, if you want to use 11.2 on your computer with ati graphics, you're going to have to follow the advice already given in this thread, (or other similar recent threads around here).

  3. #23
    Join Date
    Jun 2008
    Location
    San Diego
    Posts
    58

    Default Re: OpenSuse 11.2 Black Screen

    I have mine functioning now. When it was about to enter into the autoconfig, I hit control+c and that stopped it. Ran sax2 -r -m 0=vesa (ati or radeonhd did not work). Then rebooted, and the autoconfig worked fine. After that downloaded the drivers from ATI and everything seems to be working well.

    Thanks for the quick help.

  4. #24
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,435
    Blog Entries
    1

    Default Re: OpenSuse 11.2 Black Screen

    Glad to have been of help. Thanks for the update.

  5. #25
    anton_kolganov NNTP User

    Default Re: OpenSuse 11.2 Black Screen

    Dear all,
    I try all suggestions (failsafe mode (doesn't work), grub 3 (doesn't work), sax2 -r -m 0=vesa or ati (X server doesn't start)) - nothing helps me.
    Before I use openSUSE 11.1 without any problems.
    But I managed to run openSUSE 11.2 with "single" parameter in grub.
    Further still without success.

    Waiting for help

  6. #26
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,112
    Blog Entries
    34

    Default Re: OpenSuse 11.2 Black Screen

    Quote Originally Posted by anton_kolganov View Post
    Dear all,
    I try all suggestions (failsafe mode (doesn't work), grub 3 (doesn't work), sax2 -r -m 0=vesa or ati (X server doesn't start)) - nothing helps me.
    Before I use openSUSE 11.1 without any problems.
    But I managed to run openSUSE 11.2 with "single" parameter in grub.
    Further still without success.

    Waiting for help
    What is your graphic hardware? Please boot to run level 3 (ie press "3" (no quotes) when grub boot menu appears) and log in as a regular user. Then type 'su' (no quotes - enter root password) to temporary get root permissions.

    Then type:
    sax2 -p
    and advise here what output you get.

    Please also type:
    rpm -qa '*fglrx*'
    and advise here what output you get.

  7. #27
    anton_kolganov NNTP User

    Default Re: OpenSuse 11.2 Black Screen

    Dear oldcpu,
    I cann't boot to run level 3, after "Starting HAL daemon" black screen appears.
    I can only boot with "single" option in grub.
    My video card is Mobile Radeon X1600, sax2 -p successfully detects it.
    And empty string after querying rpm -qa "fglrx"

  8. #28
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,112
    Blog Entries
    34

    Default Re: OpenSuse 11.2 Black Screen

    Quote Originally Posted by anton_kolganov View Post
    I cann't boot to run level 3, after "Starting HAL daemon" black screen appears.
    I can only boot with "single" option in grub.
    What do you mean by "single" option" ? Do you mean you press "1" to boot to run level 1 ?

    Can you select the fail safe boot option, press '3' there (to have it boot to run level 3) and then boot to an ascii text log in at run level 3 ?

  9. #29
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,112
    Blog Entries
    34

    Default Re: OpenSuse 11.2 Black Screen

    Quote Originally Posted by anton_kolganov View Post
    I try all suggestions (failsafe mode (doesn't work), grub 3 (doesn't work), sax2 -r -m 0=vesa or ati (X server doesn't start)) - nothing helps me.
    Before I use openSUSE 11.1 without any problems.
    But I managed to run openSUSE 11.2 with "single" parameter in grub.
    Further still without success.
    If you can not boot to run level 3, you have bigger problems than your graphics/black screen.

    i'm thinking you could have a problem with the kernel. What is your computer motherboard manufacturer/model number ? (or laptop model number if this is a laptop).

  10. #30
    anton_kolganov NNTP User

    Default Re: OpenSuse 11.2 Black Screen

    Single option = "single" string in grub, yes, it means to boot to run level 1, I think.
    If I try to boot in falesafe mode with "3" I get black screen again after "starting HAL daemon": screen flashes and black screen appears

Page 3 of 14 FirstFirst 1234513 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •