Page 11 of 14 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 133

Thread: OpenSuse 11.2 Black Screen

  1. #101
    justm3 NNTP User

    Default Re: OpenSuse 11.2 Black Screen

    Edit:
    Thanks a lot man! I have Radeon X1950 Pro and received the scary black-screen during the installation when yast2 was about to start. I used CTRL+F1 and CTRL+C and logged in as the root. Your sax2 -r -m 0=vesa gave some response. I guess that wasnt enough (or maybe I just didnt reboot, dont remember anymore) but I went then directly to the last desperate renaming xorg.conf.install u suggested and rebooted, and lo' and behold black screen wouldnt come!!

    PS: Cheers to the admin policy about not allowing editing after 10 minutes.

    PS2: Just got the installation finished and working. Beautiful!
    Last edited by justm3; 10-Dec-2009 at 13:18. Reason: Added PS2.

  2. #102

    Default Re: OpenSuse 11.2 Black Screen

    It appears that the only fix needed is a fixed xorg-x11-driver-video package. It is available in the X11:/XOrg:/11.2 repository.

  3. #103
    deaven NNTP User

    Default Re: OpenSuse 11.2 Black Screen

    The problem can be worked around by doing the following:

    1) Install using the live CD. At the end of this process, the screen will go black but the first phase of the install to disk will have completed.

    2) Reboot off the live CD. Log in as root (no password needed), mount the disk, and move /usr/bin/Xorg binary to something else so that it cannot be executed. I replaced it with a shell script which does nothing, but you can probably just move it.

    3) Reboot without the live CD, and the install will continue in text mode after complaining a bit.

    4) Once you are up and running, move Xorg back and configure your X11 subsystem correctly.

  4. #104

    Default Re: This fix may work for both xpress 200 and 600 cards

    The workaround for the BlackScreen (BSD) of OpenSUSE, using vga mode 0xf06 did not work for me.

    My case is probably similar to the one in this post. I hold an acer aspire 5100 with an ATI Radeon Xpress 1100, which supposedly works on a Radeon 200M driver. Installing openSUSE 11.2 went nicely and even I got access to the first config run. At the end, the well described BSD of this post hit me, which we all know we hate.

    Trying several things in this post I have got access to my openSUSE 11.2 box -- temporarily.

    My temporal solution has been to change my runlevel to 3 (in /etc/initab). After log in in console mode, su to root and
    # rm /etc/X11/xorg.conf && sax2 -a
    and then edit the Device[0] entry in my shining new xorg.config from
    Driver "fglrx" to Driver "ati" or Driver "radeon", with vim.
    Then, either
    $ su -c 'init 5'
    or
    $ startx
    allows me to regain accession; and using this command for a round of boots goes well.Importantly, if I change my runlevel to 5 either in /etc/initab or in boot options at boot time, then, welcome back to the BSD.

    # sax2 -r -m 0=xxx, (xxx being ati or radeon, worked OK a few times). Specially, after installing the ati drivers using yast2, the #sax2 -r -m 0=ati just collapses in a never ending process that I use now to
    CTRL+C -ed it. Also #sax2 -r -m 0=radeon fails but in a more silent way, regaining access to the prompt without apparent major changes. Also after the updating of ati drivers, the "check this configuration" page appear no longer. Only the #sax2 -a option seems to work the way I already described, leaving a number of warning messages in the screen which I can give you later if you think they may be important.

    Back to your suggestions, I tried the vga mode 0xf06, and then ran a boot with a runlevel 5. Same BSD. Not counting that the loading text in this VGA mode is very gross. Big white characters in a black screen. I did not tried this mode in a runlevel 3, because it just made no sense at all.

    More things I tried, to keep long a long story!. I tried to install the drivers in the ati webpage, suggested somewhere around in the openSUSE community. It did not went OK for me. I got stuck in creating packages (I tried drivers 9.1, 9.2, and 9.3) for SuSE distro. Building package failure that I could not overpass by anyways. Beyond the very uncomfortable SUSE111-AMD64 option, knowing that I am trying to run a SUSE112-AMD64 machine. Failing in building packages, I even did not try to install them! -- leaving me without any glx rendering.

    And finally (you may be saying, thanks god), I also tried to use my dual monitor sets - for a DLP projector. It went well, by manually tweeking my /etc/X11/xorg.conf, adding additional Device[1], Screen[1] and Monitor[1] entries and modifying the ServerLayout entry for Clone "on" and a new Screen Screen[1] flags --- I hope I am not being cryptic here. But the main point is that if I do this tweeking of my xorg.conf nothig goes wrong and my manually login (yes the $su -c 'init 5') keeps working... UNTIL I connect my projector, play my pc in bigscreen a while. When I boot up, BSD is back with me, and now changes on the xorg.conf does not help at all. Only removing xorg.conf, running the sax2 -a and manually editing the xorg.conf file to change the driver in the graphic card from "fglrx" to either "ati" or "radeon" takes me back on charge.

    Boring!. For us that know what it is to loose the control of a Linux Box is even <u>outrageous</u>. no keyboard or mouse response, so obviously CTRL+ALT+F2 trying to get a new virtual terminal is useless. They keyboard is just unresponsive together with the BSD. Only pressing the powerbutton for a while till it forcedly shut down helps. And I do not know whether this may end up frying my /dev/sda!!.

    Thanks for trying to help all of you!

    -I

  5. #105
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    451

    Default Re: This fix may work for both xpress 200 and 600 cards

    I tried to install the drivers in the ati webpage, suggested somewhere around in the openSUSE community. It did not went OK for me. I got stuck in creating packages (I tried drivers 9.1, 9.2, and 9.3) for SuSE distro. Building package failure that I could not overpass by anyways.
    This is a known problem with the ATI driver installation. There is a workaround:

    ** Make sure you have 'patch' installed:

    Code:
    > zypper install patch
    # download the 9.10 driver package
    # run it as root so it decompresses its contents
    # copy the created (temporary) directory and close the program afterwards
    # inside <fglrx-install>/packages/SuSE/ati-packager.sh, change line 94 from

    Code:
    rpmbuild -bb --root ${TmpDrvFilesDir} --target ${ARCH} ${TmpPkgSpec} > ${TmpPkgBuildOut} 2>&1
    to:

    Code:
    rpmbuild -bb --buildroot ${TmpDrvFilesDir} --target ${ARCH} ${TmpPkgSpec} > ${TmpPkgBuildOut} 2>&1
    Execute:
    Code:
    <fglrx-install>/packages/SuSE/ati-packager.sh --buildpkg SUSE112-AMD64
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  6. #106

    Default Re: This fix may work for both xpress 200 and 600 cards

    Thanks for your help twelveeighty, all you sugested was done. Still I cannot build packages.
    * patch is installed in my sistem
    * driver 9.1 tried: actual file = ati-driver-installer-9-1-x86.x86_64.run
    * extracted with this comand: $./ati-driver-installer-9-1-x86.x86_64.run --extract fglrx-install
    Extraction worked fine
    * $ emacs fglrx-install/packages/SuSE/ati-packager.sh
    the line 94 read as you said, and I changed to read as you indicated... (--root to --buildroot). Saved and exit emacs
    * I executed $ fglrx-install/packages/SuSE/ati-packager.sh --buildpkg SUSE112-AMD64. Result message: "request package is not supported"

  7. #107
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    451

    Default Re: This fix may work for both xpress 200 and 600 cards

    Sorry if this was discussed already (this thread is 10 pages long), but have you already tried the 9.10 version of the driver? My guess is that at the time of version 9.1, 11.2 was not included in the driver installer code - hence the error...
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  8. #108

    Default Re: OpenSuse 11.2 Black Screen

    NEW SOLUTION!! afaik... lol

    Alright I spent forever screwing around with this problem, to no effect. But I eventually figured out what fixed the black screen for me, and its simple and I havent seen it posted anywhere else after looking. First Ill mention some specs, if you want to know more then just ask.

    AMD x64 4600 cpu
    ATI radeon x1250 integrated graphics
    2 GB Ram
    Samsung 22" Syncmaster LCD

    Now the solution that worked for me:
    Add to boot option:
    acpi=off

    I dont know why I tried it, Im not even fully aware of what acpi even is, but I believe I literally tried every possible solution given online and none of them worked. I could get to the Live CD and Installation by hitting F4 and then Safe Settings, but after installation it was impossible to get anything other than the black screen. I tried many things, but once I found acpi=off to work I did a complete reinstall without changing a single thing besides adding acpi=off to the boot option and it works perfectly (besides the huge text in KDE). Lmk if this works for you b/c I think it could finally be the solution we've been looking for.

  9. #109
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,143
    Blog Entries
    34

    Default Re: OpenSuse 11.2 Black Screen

    Quote Originally Posted by Supreme1012 View Post
    Now the solution that worked for me:
    Add to boot option:
    acpi=off
    Some Intel 855GM hardware (some but not all) also have a problem with X, where the only solution is acpi=off. I don't particularly like that approach myself on a laptop, as ACPI is the Advanced Configuration and Power Interface and it worries me that a laptop could over heat if power management functionality is switched OFF. I do not know that for certain - I just worry. Hence for my laptop with the Intel 855GM, I decided to remain at openSUSE-11.1 which does not need that boot code.

    I documented my tribulations here:
    Intel 855GM graphics problems w/openSUSE-11.2s 2.6.31 kernel - openSUSE Forums

  10. #110

    Default Re: OpenSuse 11.2 Black Screen

    Quote Originally Posted by oldcpu View Post
    I don't particularly like that approach myself on a laptop, as ACPI is the Advanced Configuration and Power Interface and it worries me that a laptop could over heat if power management functionality is switched OFF.
    It appears that acpi=off is mentioned in Bugs:Most Annoying Bugs 11.2 - openSUSE but wasn't posted in any of the 10 or so black screen threads that I read. I understand that it controls the power saving stuff but since Im using a desktop and I turn all of the powersaving stuff off anyways its fine for me. plus the solution is more about just being able to install and get onto KDE in the first place. Ill try upgrading everything and then seeing if I can log in without turning acpi off.

Page 11 of 14 FirstFirst ... 910111213 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •