Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Chinese Input and Suse 11.2

  1. #1

    Default Chinese Input and Suse 11.2

    Hi I'm new to Linux and to Suse.I want to be able to input Chinese (both simplified and traditional). I have tried searching the forums for a solution but have not found any clear guidance for doing this. I have already enabled through Yast, Chinese (traditional and simplified) as second language. I have also found Scim though Applications>System>Configuration.In the SCIM settings I disabled all of the other languages except the ones i need and set the GTK toolbar to show up in the system tray. I have also through the configure desktop option enabled the keyboard layout to switch between China (chinese) and USA (english). After doing these things I am still unable to input Chinese. Any guidance would be greatly appreciated.

  2. #2
    Join Date
    May 2009
    Jakarta, Beijing

    Default Re: Chinese Input and Suse 11.2

    you can enable the chinese IME by changing your primary language to chinese, at YAST, then logout.
    After logging back in again, the chinese IME should be working.
    You can change the primary language back to english afterwards.

    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  3. #3
    a14331990 NNTP User

    Default Re: Chinese Input and Suse 11.2

    To input Chinese, install scim-pinyin and scim is enough.
    Please don't set Chinese as your primary language,it won't help, and mess up your menus with a lot of Chinese characters.I believe that there is a bug with scim-panel-gtk: the keyboard-like tray icon won't shown on GNOME panel after login.I guess that scim-panel-gtk was not initialized properly, so kill it, and it will start automatically again. Here is a workaround:
    Put this script in Control Center -> System -> Startup Applications:

    killall scim-panel-gtk



  4. #4
    nakas NNTP User

    Default Re: Chinese Input and Suse 11.2

    I also have a problem similar to adsum01nl.
    I can't write in japanese. I have already installed japanese language support (through YaST), installed scim and scim-anthy and the keyboard on the panel appeared but it wouldn't let me change to anthy input. I could change the settings and anthy settings appeared there but neither the shortcuts nor the "crown" (simbol of anthy) appeared. After that I tried to install skim, skim-anthy (I'm on kde) and even UMI and they all started up but the option to change input never appeared.

    Thanks in advance for the help.

  5. #5
    nakas NNTP User

    Default Re: Chinese Input and Suse 11.2

    I found one solution.
    Basically I just installed scim and scim-anthy (in my case), and edited /etc/profile.d/ with these lines at the bottom:

    #Set the LANG to your preferred locale. #locale -a to see locales supported
    export LANG=en_US.UTF-8
    export XMODIFIERS=@im=SCIM
    export GTK_IM_MODULE=xim
    export QT_IM_MODULE=xim
    Then, reboot the pc, and then input "scim -d" in a terminal.
    In the SCIM setup, check every option in the toolbar section (I guess this step is optional but I think the interface is friendlier with those options enabled).

    The only disadvantage I see is that you need to call the comand every time you login (or you could just edit the startup scripts).

  6. #6

    Default Re: Chinese Input and Suse 11.2

    Hello I have tried the solutions suggested by maill and by a14331990. Sadly neither have worked. Regarding your solution nakas I am too inexperienced to try this. Can you either give more simplified instructions for doing this or can someone give a "newbe solution" for doing Chinese input? BTW I don't know if anyone else has tried it but the Google pinyin application for windows works pretty good. If only they could have a Linux version...It seems that this SCIM is not the best solution. Any thoughts any good resolution from someone who is using Chinese characters in Open Suse. I would start to rant in Chinese but then I would have to boot my windows machine.

  7. #7

    Default Re: Chinese Input and Suse 11.2

    Wow, seems like a very complex solution. I didn't have much of an issue.

    The scim packages were installed automatically when I selected Chinese as a secondary language. If you're wanting to type using hanyu pinyin, then making sure scim-pinyin package is installed should be enough.

    Then ctrl+space is the default key binding for turning chinese input on/off. I had a little bug in kde that the tray icon wasn't displayed, even though it was set to. I simply opened the SCIM setup (use ctrl+space to activate SCIM and then click on the menu button). Under Panel-->GTK, deselect, the reselect 'Show tray icon' then save the changes. It should show up from now on.

    pinyin may not be the default input method. On the menu bar, select the first button and you can select pinyin input from there.

    Sorry, not the most clear instructions. You can message me on irc, nick: 'Benoni'. I'll be on for the next few hours if you want a hand.


  8. #8

    Default Re: Chinese Input and Suse 11.2

    Oh, and about SCIM not being the best solution:

    IMHO, SCIM rocks. Once you get the hang of it, it's dead easy. I have it set up so ctrl+space toggles SCIM on/off, shift+space turns jyutping input on and alt+space turns pinyin input on. So I can input Cantonese or Mandarin quickly and easily. Jyutping input is quite rubbish I have to admit. It's much easier to just use pinyin in traditional mode. Even then it will take a little while for it to learn all the traditional compounds.

    However, out of the box, it's smashing for simplified pinyin.

    my 2p,


  9. #9

    Default Re: Chinese Input and Suse 11.2

    Benoni 汉子能写了!谢谢!Smart Pinyin is a great setting to type traditional and simplified Chinese. I agree with you on the bug. In the SCIM setup I also had to uncheck and recheck the "show tray icon" in the GTK panel. In fact I think this bug is what was giving me all of the trouble in the first place. Thanks for pointing it out and hopefully it gets fixed soon! PS thanks for the quick reply these Open Suse forums rock and I think it is the great people in here like you who make OpenSuse a great distro!


  10. #10

    Default Re: Chinese Input and Suse 11.2

    Sorry, just ignore what is below. I miss-read adsum01nl's post, reading his first, rather than latest post - silly boy


    Don't know what you mean by the configure desktop option. Sounds like a KDE/Gnome control centre? You want to configure the shortcuts through SCIM.

    Have you tried ctrl+space? What happens?

    What happens if you left-click on the SCIM desktop icon, point to 'Chinese (simplified)' and then on 'Smart Pinyin'?

    Last edited by BenoniH; 01-Dec-2009 at 10:30. Reason: Miss read the post order and replied to the wrong thing.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts