Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Firefox fails to start after upgrading to openSUSE 11.2

  1. #1
    Join Date
    Nov 2009
    Location
    Finland
    Posts
    9

    Default Firefox fails to start after upgrading to openSUSE 11.2

    Hi,

    After upgrading from opensuse 11.1 to 11.2 via zypper dup. Firefox won't start anymore. When i try to launch Firefox from konsole following error presents:

    Code:
    /usr/lib/firefox/firefox: symbol lookup error: /usr/lib/xulrunner-1.9.1.4/libxul.so: undefined symbol: gdk_x11_window_get_drawable_impl

    Following versions installed:

    MozillaFirefox-3.5.4-1.1.2.i586
    mozilla-xulrunner191-1.9.1.4-2.1.2.i586

    Tried also reinstall firefox and xulrunner multiple times. Also tried different versions of xulrunner. Is this issued caused by xulrunner or something else ?

    Thanks for any help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    First thing I would try is a rename of the hidden .mozilla folder to .mozilla-old
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2009
    Location
    Finland
    Posts
    9

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Quote Originally Posted by caf4926 View Post
    First thing I would try is a rename of the hidden .mozilla folder to .mozilla-old
    Thanks for reply, but no help. I also tried to create a new account, but this error still occurs.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Are you using gnome?.

    I'd be interested in seeing your repos

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Nov 2009
    Location
    Finland
    Posts
    9

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Quote Originally Posted by caf4926 View Post
    Are you using gnome?.

    I'd be interested in seeing your repos

    Code:
    zypper lr -d
    I'm using KDE.

    Code:
    # | Alias                       | Name                        | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    --+-----------------------------+-----------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1 | GNOME:Factory               | GNOME:Factory               | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_11.2/  |
    2 | KDE:Backports               | KDE:Backports               | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.2/  |
    3 | OpenSUSE_11.2_Factory_GNOME | OpenSUSE_11.2_Factory_GNOME | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_11.2   |
    4 | mozilla                     | mozilla                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |
    5 | mozilla:beta                | mozilla:beta                | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/beta/openSUSE_11.2/   |
    6 | mozilla:legacy              | mozilla:legacy              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/legacy/openSUSE_11.2/ |
    7 | repo-non-oss                | openSUSE-11.2 Non-OSS       | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/             |
    8 | repo-oss                    | openSUSE-11.2 OSS           | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                 |
    9 | repo-update                 | openSUSE-11.2 Updates       | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                |
    Thanks,

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Disable 5 and 6
    Change priority of 4 to 90

    Now Use Software Management - Filter by repo
    select the Mozilla
    Use the System Package switch to use this repo (principle shown here: ImageBam - Fast, Free Image Hosting and Photo Sharing)
    Accept
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2009
    Location
    Finland
    Posts
    9

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Quote Originally Posted by caf4926 View Post
    Disable 5 and 6
    Change priority of 4 to 90

    Now Use Software Management - Filter by repo
    select the Mozilla
    Use the System Package switch to use this repo (principle shown here: ImageBam - Fast, Free Image Hosting and Photo Sharing)
    Accept
    Sorry. That did'n help either. I noticed that same error occurs with Mozilla Sunbird and Thunderbird.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    So remove all the mozilla repos and switch everything back to default oss/updates

    See if that helps
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Nov 2009
    Location
    Irun (Basque Country-Spain)
    Posts
    13

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Hi.
    I had similar problem and it was solved removing Gecko media player. Good luck!

  10. #10
    Join Date
    Nov 2009
    Location
    Finland
    Posts
    9

    Default Re: Firefox fails to start after upgrading to openSUSE 11.2

    Problem solved! At least for now.. I'm not 100 % sure what i did, but i downgraded firefox and related packages (xulrunner) to orginal versions from 11.2 repo. Slept over night and rebooted my computer and firefox is running nice and smooth.

    Thank you for replies!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •