Results 1 to 6 of 6

Thread: Xcircuit for Opensuse 11.0

  1. #1

    Default Xcircuit for Opensuse 11.0

    Hello all,

    Being somewhat new to linux, i wanted to use xcircuit (for publishing my schematic entries in easy .eps like format for latex)
    I was looking into xcircuit rpm, and found this for opensuse.
    Is it a workable solution to download this rpm:

    RPM Search xcircuit-3.6.132-2.1.i586.rpm

    If theres an easy way plz suggest to have xcircuit running?

  2. #2

    Default Re: Xcircuit for Opensuse 11.0

    Ok i started the make install, and found the following missing aclocal error for my xcircuit rpm. Could anyone suggest what is missing ?

    HTML Code:
    make install
    cd . && /bin/sh /tmp/xcircuit/missing --run aclocal-1.9
    /tmp/xcircuit/missing: line 46: aclocal-1.9: command not found
    WARNING: `aclocal-1.9' is needed, and you do not seem to have it handy on your
             system.  You might have modified some files without having the
             proper tools for further handling them.  Check the `README' file,
             it often tells you about the needed prerequirements for installing
             this package.  You may also peek at any GNU archive site, in case
             some other package would contain this missing `aclocal-1.9' program.
    make: *** [aclocal.m4] Error 1
    

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,205
    Blog Entries
    15

    Default Re: Xcircuit for Opensuse 11.0

    Quote Originally Posted by xizzling
    Ok i started the make install, and found the following missing aclocal
    error for my xcircuit rpm. Could anyone suggest what is missing ?


    make install
    cd . && /bin/sh /tmp/xcircuit/missing --run aclocal-1.9
    /tmp/xcircuit/missing: line 46: aclocal-1.9: command not found
    WARNING: `aclocal-1.9' is needed, and you do not seem to have it handy
    on your
    system. You might have modified some files without having
    the
    proper tools for further handling them. Check the `README'
    file,
    it often tells you about the needed prerequirements for
    installing
    this package. You may also peek at any GNU archive site, in
    case
    some other package would contain this missing `aclocal-1.9'
    program.
    make: *** [aclocal.m4] Error 1
    Hi
    Normally you can search here;
    http://software.opensuse.org/search?
    xcircuit is in the hamradio repository no need to build;
    http://software.opensuse.org/search?...p=1&q=xcircuit

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 11:33, 2 users, load average: 0.45, 0.15, 0.08
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  4. #4

    Default Re: Xcircuit for Opensuse 11.0

    Oh , thank you so much for this help. You saved my time!

  5. #5

    Talking Re: Xcircuit for Opensuse 11.0

    Thank you for your help! Saved my time trying to find xcircuit.

    Not trying to be a beeech here, but hey, HAMRADIO?
    I guess that was the only area where circuits needed simulation back in the gue'O days of 1950.


    Quote Originally Posted by malcolmlewis View Post
    Hi
    Normally you can search here;
    software.opensuse.org: Search
    xcircuit is in the hamradio repository no need to build;
    software.opensuse.org:

    --
    Cheers Malcolm ��� (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 11:33, 2 users, load average: 0.45, 0.15, 0.08
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Xcircuit for Opensuse 11.0

    On 2012-07-10 17:46, secondox wrote:
    >
    > Thank you for your help! Saved my time trying to find xcircuit.
    >
    > Not trying to be a beeech here, but hey, HAMRADIO?
    > I guess that was the only area where circuits needed simulation back in
    > the gue'O days of 1950.


    gEDA is in the Science repo. It is curious indeed that they are not in the
    same repo.

    Tried it... very simple. Did not manage to do anything with it, and it crashed:

    Code:
    cer@Telcontar:~> xcircuit &
    [1] 17572
    cer@Telcontar:~> Warning: Actions not found: delete-next-character
    Warning: Actions not found: delete-next-character
    Warning: Actions not found: delete-next-character
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
    after 14364 requests (14363 known processed) with 0 events remaining.
    
    [1]+  Exit 1                  xcircuit

    The menu above does not work. I click on "File", nothing happens.

    I do not like it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •