Results 1 to 2 of 2

Thread: Image Creator - Miscellaneous Issues

  1. #1

    Default Image Creator - Miscellaneous Issues

    I've got openSUSE 11.2 RC2 installed, and I'm experimenting with the Product Creator. So far I've added the OSS and Updates repos,and selected the KDE desktop. I'm getting this error message:

    #### YaST2 conflicts list - generated 2009-11-11 08:59:57 ####

    pattern:kde4-11.2-20.22.1.x86_64 requires pattern:kde4_basis, but this requireme
    nt cannot be provided
    uninstallable providers: pattern:kde4_basis-11.2-20.22.1.x86_64[repo-oss]
    pattern:kde4_basis-11.2-20.22.1.i586[repo-oss]
    [ ] break kde4 by ignoring some of its dependencies

    [ ] do not install suse-build-key-1.0-909.5.noarch

    [ ] do not install pattern:kde4-11.2-20.22.1.x86_64

    #### YaST2 conflicts list END ###

    If I select the second option, "do not install suse-build-key", it goes ahead and selects kde4_basis and populates the package list. Is this a problem? Does the "suse-build-key" exist in another repo?

  2. #2

    Default Re: Image Creator - Miscellaneous Issues

    Quote Originally Posted by znmeb View Post
    I've got openSUSE 11.2 RC2 installed, and I'm experimenting with the Product Creator. So far I've added the OSS and Updates repos,and selected the KDE desktop. I'm getting this error message:

    #### YaST2 conflicts list - generated 2009-11-11 08:59:57 ####

    pattern:kde4-11.2-20.22.1.x86_64 requires pattern:kde4_basis, but this requireme
    nt cannot be provided
    uninstallable providers: pattern:kde4_basis-11.2-20.22.1.x86_64[repo-oss]
    pattern:kde4_basis-11.2-20.22.1.i586[repo-oss]
    [ ] break kde4 by ignoring some of its dependencies

    [ ] do not install suse-build-key-1.0-909.5.noarch

    [ ] do not install pattern:kde4-11.2-20.22.1.x86_64

    #### YaST2 conflicts list END ###

    If I select the second option, "do not install suse-build-key", it goes ahead and selects kde4_basis and populates the package list. Is this a problem? Does the "suse-build-key" exist in another repo?
    That one turned out to be a package conflict between "suse-build-key" and "opensuse-build-key" So I got past it.

    Next issues: I'm trying to make a USB stick. I selected the KDE Desktop and the "do not install suse-build-key". The subsequent build attempt crashed on a package conflict between "nscd" and "unscd" - it looks like it's trying to install both of them. So I selected "unscd" and restarted.

    Now it's giving me some kind of filesystem allocation error trying to make an 8 GB USB stick:

    Nov-11 22:15:42 <1> : Image requires 3387 MB, got 8G MB done
    Nov-11 22:15:42 <1> : Suggested Image size: 4403 MB done
    Nov-11 22:15:42 <1> : EXEC [dd if=/dev/zero of=/tmp/KDE-11.2/KDE-11.2.x86_64-1.0.0 bs=1 seek=8388607 count=1 2>&1]
    Nov-11 22:15:43 <1> : EXEC [/sbin/mke2fs -i 16384 -O resize_inode -T ext3 -j -F -N 296754 /tmp/KDE-11.2/KDE-11.2.x86_64-1.0.0 2>&1]
    Nov-11 22:15:43 <3> : Couldn't create EXT2 filesystem failed
    Nov-11 22:15:43 <3> : mke2fs 1.41.9 (22-Aug-2009)
    mke2fs: inode_size (256) * inodes_count (296754) too big for a
    filesystem with 2048 blocks, specify higher inode_ratio (-i)
    or lower inode count (-N).

    Nov-11 22:15:43 <3> : KIWI exited with error(s) done


    -------

    So ... next attempt I will cut the 8 GB down to 5 GB and see if that helps. Watch this space :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •