Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Video Choppy

  1. #1
    Join Date
    Oct 2008
    Location
    Guelph, ON, Canada
    Posts
    47

    Default Video Choppy

    I recently upgraded all packages needing upgrading in yast, and it seems this has negatively affected my video players. When I try to watch an mkv/avi file in Xine, MPlayer or VLC, the video is very choppy, and my computer starts to heat up (70C instead of 50C).

    Does anyone know why this is happening, and how to fix it? This didn't used to happen until fairly recently.

    Thanks
    Laptop: Thinkpad T61p | Intel Core 2 Duo T9500 2.6GHz | 4Gb RAM | nVidia Quadro FX 570M
    System: OS 11.4 x86_64 | KDE 4.6.0 "Release 6" | Kernel 2.6.37.6-0.7

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Video Choppy

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: Video Choppy

    Quote Originally Posted by dkvasnic View Post
    I recently upgraded all packages needing upgrading in yast, and it seems this has negatively affected my video players. When I try to watch an mkv/avi file in Xine, MPlayer or VLC, the video is very choppy, and my computer starts to heat up (70C instead of 50C).
    I do not know why your computer starts to heat up. Just how racy are those videos?

    But refering the jerkiness, what are you using for an output video module? Most players will let you select that. See if you can try another setting, ... possibly if 'x11' is selected, select instead 'xv'.

    Also, what graphic driver are you using? If a proprietary graphic driver, have you rebuilt it since the last kernel update?

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Video Choppy

    Quote Originally Posted by oldcpu View Post
    I do not know why your computer starts to heat up. Just how racy are those videos?
    Now that's funny - quote of the week so far.

    @dkvasnic, some hardware details would be helpful and assuming you are using openSUSE, its release level, KDE or Gnome level (or other DE) and any other mentioned software release levels would be a start.

  5. #5
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Video Choppy

    Hmm, for some reason I didn't see the stuff at the bottom of @dkvasnic's post, and I specifically looked for it. Anyway, what is the processor utilization during the choppy video?? Running the command "Top" in a terminal will show it.

  6. #6
    Join Date
    Oct 2008
    Location
    Guelph, ON, Canada
    Posts
    47

    Default Re: Video Choppy

    Quote Originally Posted by caf4926 View Post
    So I followed the instructions in that thread, and after numerous adding/removing/vendor changing of packages and repositories, I'm still having the same issue.
    Laptop: Thinkpad T61p | Intel Core 2 Duo T9500 2.6GHz | 4Gb RAM | nVidia Quadro FX 570M
    System: OS 11.4 x86_64 | KDE 4.6.0 "Release 6" | Kernel 2.6.37.6-0.7

  7. #7
    Join Date
    Oct 2008
    Location
    Guelph, ON, Canada
    Posts
    47

    Default Re: Video Choppy

    Quote Originally Posted by oldcpu View Post
    I do not know why your computer starts to heat up. Just how racy are those videos?

    But refering the jerkiness, what are you using for an output video module? Most players will let you select that. See if you can try another setting, ... possibly if 'x11' is selected, select instead 'xv'.

    Also, what graphic driver are you using? If a proprietary graphic driver, have you rebuilt it since the last kernel update?
    I have the output video module set to default, however I tried selecting xv and x11 (and restarting the program to enable them), which didn't fix the problem.

    My graphics driver is from the opensuse repository: x11-video-nvidiaG02
    Laptop: Thinkpad T61p | Intel Core 2 Duo T9500 2.6GHz | 4Gb RAM | nVidia Quadro FX 570M
    System: OS 11.4 x86_64 | KDE 4.6.0 "Release 6" | Kernel 2.6.37.6-0.7

  8. #8
    Join Date
    Oct 2008
    Location
    Guelph, ON, Canada
    Posts
    47

    Default Re: Video Choppy

    Quote Originally Posted by consused View Post
    Hmm, for some reason I didn't see the stuff at the bottom of @dkvasnic's post, and I specifically looked for it. Anyway, what is the processor utilization during the choppy video?? Running the command "Top" in a terminal will show it.
    The choppiness is worse in fullscreen then non-fullscreen.

    Here is what Top gives me (when xine was NOT in fullscreen):

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3182 root 20 0 481m 135m 59m R 96 3.5 3:58.01 Xorg
    4876 david 20 0 722m 125m 67m S 42 3.2 0:08.68 xine
    3719 david 20 0 258m 10m 9740 S 3 0.3 0:02.72 pulseaudio
    3720 david 20 0 137m 13m 8880 S 1 0.3 0:05.06 knetworkmanager
    4370 david 20 0 489m 97m 25m S 1 2.5 0:19.37 firefox
    4785 root 20 0 370m 84m 25m S 0 2.2 0:06.01 y2base
    1 root 20 0 1064 388 324 S 0 0.0 0:00.54 init
    2 root 15 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
    3 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/0
    4 root 15 -5 0 0 0 S 0 0.0 0:00.08 ksoftirqd/0
    5 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/1
    6 root 15 -5 0 0 0 S 0 0.0 0:00.02 ksoftirqd/1
    7 root 15 -5 0 0 0 S 0 0.0 0:00.08 events/0
    8 root 15 -5 0 0 0 S 0 0.0 0:00.08 events/1
    9 root 15 -5 0 0 0 S 0 0.0 0:00.00 khelper
    10 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/0
    11 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/1
    Laptop: Thinkpad T61p | Intel Core 2 Duo T9500 2.6GHz | 4Gb RAM | nVidia Quadro FX 570M
    System: OS 11.4 x86_64 | KDE 4.6.0 "Release 6" | Kernel 2.6.37.6-0.7

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: Video Choppy

    Quote Originally Posted by dkvasnic View Post
    My graphics driver is from the opensuse repository: x11-video-nvidiaG02
    I don't know what that is. ... I think it is the openGL driver and its quiet possible the openGL driver does not handle your nVidia Quadro FX 570M on your Intel Core 2 Duo T9500 PC very well. When I first installed openSUSE-11.1 on my Intel Core i7 920 with a nVidia GTX 260, I found the graphic performance pathetic, with the sort of jerkiness you describe. Turns out back then the openGL driver did not work well with my PC. but the proprietary graphic driver worked well.

    How good is your Linux knowledge? You could install the proprietary nVidia graphic driver. I prefer to do this "the hardway" which is not hard. Guidance is here: NVIDIA/The hard way - openSUSE

    In essence:
    • (1) go to YaST > Software > Software management, and change the "filter" to "patterns" and select the "Base Development" pattern and install the associated apps. Then ensure you have the 2.6.27.37 kernel version of kernel-source and kernel-syms installed, and also install linux-kernel-headers.
    • (2) go to NVIDIA DRIVERS 190.42 Certified and download NVIDIA-Linux-x86_64-190.42-pkg2.run to your hard drive (say to /home/your-user-name)
    • (3) reboot your PC to run level 3 (type '3' in grub boot menu so the "3" appears in the options line), continue with the boot, and log in at text prompt as regular user. Then type "su" to get root permissions, and enter root password. Then navigate to /etc/X11/xorg.conf and move the exisiting xorg.conf file to a backup name:
      Code:
      mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup
      I say backup so you can restore it later.
    • (4)then while you still have root permissions, navigate to /home/your-user-name where the NVIDIA-Linux-x86_64-190.42-pkg2.run file is located, and run it with:
      Code:
      sh NVIDIA-Linux-x86_64-190.42-pkg2.run -q
    • (5) when it is complete, then configure your nVidia graphics with:
      Code:
      nvidia-xconfig
      which will create a new /etc/X11/xorg.conf file (it may complain it can't find the old). Note, you probably do NOT have to run " sax2 -r -m 0=nvidia " as the file created by "nvidia-config" should be good enough.
    • (6)then reboot with "shutdown -r now" and see if that works

    If you end up with no GUI, restart, type '3' again in grub boot menu, logon to text prompt as a regular user, then type "su" to get root/admin permissins, restore the backed copy of /etc/X11/xorg.conf (which you called xorg.conf.mybackup) and then restart and you are back to where you were before with nothing lost for your efforts, but some lost time.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: Video Choppy

    To confirm you are not using the proprietary driver yet, please type:
    Code:
    grep -i driver /etc/X11/xorg.conf
    and post here the output.

    If it says driver "nv" you are using an openGL driver. If it says driver "nvidia" you are using a nvidia proprietary driver. If it says driver 'vesa' you are using a vesa driver.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •