Results 1 to 2 of 2

Thread: Can't mount USB devices anymore...

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Posts
    77

    Default Can't mount USB devices anymore...

    Hi all,

    I used to be able to use USB flash drives and card readers and stuff like that...but for some reason I can't anymore! I'm not sure why.

    For this test I'll use a flash card reader that I know works with a 1gb uSD card plugged into it that I also know works.

    Code:
    [nathan@ebisu ~] lsusb
    ...
    Bus 004 Device 016: ID 05e3:0715 Genesys Logic, Inc. USB 2.0 microSD Reader
    OK, so it knows its plugged in...

    Code:
    [nathan@ebisu ~] dmesg | tail
    usb 4-2: new high speed USB device using ehci_hcd and address 16
    usb 4-2: configuration #1 chosen from 1 choice
    usb 4-2: New USB device found, idVendor=05e3, idProduct=0715
    usb 4-2: New USB device strings: Mfr=3, Product=4, SerialNumber=2
    usb 4-2: Product: USB Reader
    usb 4-2: Manufacturer: Genesys
    usb 4-2: SerialNumber: 000000009407
    I don't see any errors in dmesg output...

    Code:
    [nathan@ebisu ~] sudo tail /var/log/messages
    root's password:
    Nov  9 22:41:00 ebisu kernel: usb 4-2: new high speed USB device using ehci_hcd and address 16
    Nov  9 22:41:00 ebisu kernel: usb 4-2: configuration #1 chosen from 1 choice
    Nov  9 22:41:00 ebisu kernel: usb 4-2: New USB device found, idVendor=05e3, idProduct=0715
    Nov  9 22:41:00 ebisu kernel: usb 4-2: New USB device strings: Mfr=3, Product=4, SerialNumber=2
    Nov  9 22:41:00 ebisu kernel: usb 4-2: Product: USB Reader
    Nov  9 22:41:00 ebisu kernel: usb 4-2: Manufacturer: Genesys
    Nov  9 22:41:00 ebisu kernel: usb 4-2: SerialNumber: 000000009407
    I don't see any error message in the syslog...

    Code:
    [nathan@ebisu /proc/scsi] cat scsi
    Attached devices:
    Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: ST3400620AS      Rev: 3.AA
      Type:   Direct-Access                    ANSI  SCSI revision: 05
    Host: scsi6 Channel: 00 Id: 00 Lun: 00
      Vendor: BENQ     Model: DVD DD DW1640    Rev: BSRB
      Type:   CD-ROM                           ANSI  SCSI revision: 05
    It doesn't show up as a SCSI device...

    Code:
    [nathan@ebisu /proc/bus/usb] l
    total 0
    dr-xr-xr-x 2 root root 0 2009-11-09 22:48 .
    dr-xr-xr-x 5 root root 0 2009-11-01 08:46 ..
    My /proc filesystem doesn't appear to have *anything* in the usb branch...

    Here's my fstab, just for fun
    Code:
    [nathan@ebisu ~] cat /etc/fstab
    /dev/disk/by-id/scsi-SATA_ST3400620AS_9QH03H3T-part1    swap    swap    defaults 0 0
    /dev/disk/by-id/scsi-SATA_ST3400620AS_9QH03H3T-part2    /       ext3    acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_ST3400620AS_9QH03H3T-part3    /home   xfs     defaults 1 2
    proc    /proc   proc    defaults 0 0
    sysfs   /sys    sysfs   noauto 0 0
    debugfs /sys/kernel/debug       debugfs noauto 0 0
    usbfs   /proc/bus/usb   usbfs   noauto 0 0
    devpts  /dev/pts        devpts  mode=0620,gid=5 0 0
    ark:/mnt/bigraid        /mnt/raid       nfs     rw,soft,intr,user,noatime,exec,async,nosuid,nodev,proto=tcp,retry=10,rsize=32768,wsize=32768 0 0
    I tried the above with two other devices (a USB flash drive and an external HDD) with the same results: shows up in lsusb but doesn't mount a drive.

    Any help would be appreciated!
    Nathan

  2. #2
    Join Date
    Jun 2008
    Location
    USA
    Posts
    77

    Default Re: Can't mount USB devices anymore...

    So it turns out I forgot to reboot after doing a kernel update through YaST, and apparently important modules like, oh, usb-storage are unloaded and then not reloaded on kernel update. Oops.

    Sorry for wasting your time...

    Nathan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •