Results 1 to 4 of 4

Thread: kjournald and syslog-ng disk sleeping

  1. #1

    Default kjournald and syslog-ng disk sleeping

    Today, seemingly at random, I noticed that my hard disk was being accessed constantly, with the light solid on. I looked at the running processes and found "kjournald" and "syslog-ng" are in "disk sleep". I reboot the computer, and when I log in, the disk is normal again. I look at the processes and there is nothing "disk sleep"ing. Nothing is taking up any unusual processor time, even when the disk assault commences. Suddenly, about 3 minutes after rebooting, it starts again. I'm on the third reboot and still it happened again.

    Any clues? Anything I can do to figure out what is going on? I'm on 11.1 x86_64. I did not update any software today. Yesterday I believe I installed a new version of gstreamer, but after that I didn't have this behavior. Thanks for the help.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: kjournald and syslog-ng disk sleeping

    kjournald is the kernel's journaling daemon and is pretty much always active when data is accessed from disk

    Do you really need syslog-ng? Syslog-ng - Wikipedia, the free encyclopedia

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: kjournald and syslog-ng disk sleeping

    syslog-ng is the default syslog for openSUSE these days.

  4. #4

    Default Re: kjournald and syslog-ng disk sleeping

    Thanks for the replies. They actually helped me solve the problem, though I probably should have been able to on my own.

    When I read the replies, I got to looking at the various stuff in /var/log since syslog-ng was one of the offending processes, and found in my cups error_log that the cups hp backend was crashing and "with status 1". Well, not too helpful (although it did say 'Hint: Try setting the LogLevel to "debug" to find out more.' However, I don't know where this particular LogLevel is to be set) At any rate, some tooling around with HPLIP discovered some weird orphaned job sitting in my printer queue, once I deleted that, the cups backend stopped crashing, and the assaulting of my disk has ended! Huzzah.

    Thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •