Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Kwrite/Kate copy question

  1. #1

    Default Kwrite/Kate copy question

    kate 3.3.3
    kde 4.3.3

    I use kate as my editor.

    If I select some text and then copy the
    selected text using Ctrl-c and paste the
    the copied text into another document without prior deselecting the copied text in the original document, the Ctrl-c command acts like a Ctrl-x command.

    How can I avoid that ?

    Thanks
    Db

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,442

    Default Re: Kwrite/Kate copy question

    This sounds like a regression. It certainly doesn't do this in earlier versions as I regularly use it in that way.

    Check https://bugs.kde.org/

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,872

    Default Re: Kwrite/Kate copy question

    In a KDE (and Gnome I presume, because this behaviour existed allready in CDE on HP-UX and Solaris) one slelects a piece of text by left-click-down at one end, move to the other end and release left-button. Then this text is "under the mouse". Move the mouse to another place (can be in another window) andd to paste a copy, only click the middle-button. No need for keyboard access at all (even not two hands because of the Cntrl-key).
    Henk van Velden

  4. #4

    Default Re: Kwrite/Kate copy question

    Yes, I know...however this does not change the fact , that the text disappears from the original document.

    If you copy in the same document this issue does not manifest itself, because the originally selected text is automatically deselected if you move the cursor to another position and do the insert , be it via middle button click or ctrl-v




    Db

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: Kwrite/Kate copy question

    Tested on both my machines. Works like it should. I.e. not like yours. Using keyboard shortcuts and mouse. Which KDE are you on?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Kwrite/Kate copy question

    KDE 4.3.3 release 1
    Kate 3.3.3
    opensuse 11.1

    I hope I am not the only one having this issue ...

    Db

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: Kwrite/Kate copy question

    Did you try creating a new user, and see if the phenomenon exists when the new user logs in?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: Kwrite/Kate copy question

    Created a new user.
    Phenomenon remains the same.

    Db

  9. #9

    Default Re: Kwrite/Kate copy question

    this problem happened to me also.

    text editor issue - openSUSE Forums

  10. #10
    palladium NNTP User

    Default Re: Kwrite/Kate copy question

    jolestar wrote:
    > this problem happened to me also.


    how are the KDE developers progressing on resolving the bug you (or
    someone else) logged with them?

    --
    palladium
    Have a lot of fun..

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •