Results 1 to 6 of 6

Thread: Gtk-WARNING **: Cannot open display

  1. #1
    phulsebo NNTP User

    Default Gtk-WARNING **: Cannot open display

    Hello,
    I am new in using SuseLinx version 10.2. My machine used to boot up fine and I arrived in the GUI desktop. I have installed VMWare Server 2.0 and this was running fine. I was able to login with the Firefox browser that was installed.

    When booting now, I end up in a command prompt. Giving the command "desktop-launch" I wait 10 seconds and get the error (firefox-bin:5239): Gtk-WARNING **: cannot open display:

    I researched some forums, tried a couple of things, but can not get it back working again.

    - when I execute xhost localhost I get xhost: unable to open display ""
    - when I do export DISPLAY=:0 I get back to my prompt
    - when I type echo $DISPLAY I get localhost:0.0
    - when I enter kde then the output is kstartupconfig: error while loading shared libraries: libkdefakes.so4: cannot open shared object file: No such file or directory
    I tried it already as su but this does not work either.

    Please please help me with this. I am stuck here.

    Regards,
    Philip

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Gtk-WARNING **: Cannot open display

    * phulsebo wrote, On 11/06/2009 10:36 PM:
    >
    > Hello,
    > I am new in using SuseLinx version 10.2.


    This isn't supported any more, for almost a year now. Please upgrade to 11.1 or wait a couple of days until 11.2 is being released.

    Uwe

  3. #3
    phulsebo NNTP User

    Default Re: Gtk-WARNING **: Cannot open display

    Hello Uwe,

    I thought this was a forum, not the official Suse Support.

    The Suse 10.2 installation came with a new PC from Dell. I had chosen this version over that of 11.0 , because VMWare Server 2 only supports 10.

    Maybe my question is too difficult, or I did not give the correct details to answer. If there is nobody that can help here I will have to open a case with Suse support or abandon this experiment and move over to MS Windows which I know better to troubleshoot myself.

    Regards,
    Philip

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Gtk-WARNING **: Cannot open display

    VMware products run fine on all openSUSE versions.

    I think you've missed something. There's SUSE Linux, Novell's licensed version, and there's openSUSE, the community based version sponsorred by Novell. VMware refers to SUSE Linux Enterprise (server/desktop) 10, you have openSUSE 10.2. openSUSE versions have a certain life cycle after which support with updates etc. stops. Since 10.2 (and 10.3 in a while) is past the end of it's life cycle, you will not be able to find packages etc, i.e. have to manually compile and install stuff.

    I'm sure VMware Server runs on 11.0, 11.1 and 11.2, so that's not the problem. I strongly suggest you download 11.1 or wait a couple of days and download 11.2, install it, run it and be surprised. I see VMWare Server running every other day, on 11.1 and 11.2 RC2 (testserver).

    BTW Welcome to the forums. Don't give up, there's about 36000 people here to help you.

    In short: do yourself a favor and do not stick to 10.2. Install the latest stable version and you'll be much better of.
    Last edited by Knurpht; 09-Nov-2009 at 05:44. Reason: Forgot welcome
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Gtk-WARNING **: Cannot open display

    * phulsebo wrote, On 11/09/2009 08:36 AM:
    > The Suse 10.2 installation came with a new PC from Dell.


    In this case I assume you are not using openSUSE, but Suse Linux Enterprise Desktop 10 SP2. Totally different beast.

    Please check the SLED forums on forums.novell.com in this case. Or, if you have maintenance, open an incident with Novell.

    Uwe

  6. #6
    phulsebo NNTP User

    Default Re: Gtk-WARNING **: Cannot open display

    Thanks for the replies and even more - the clarification on this subject. Yes, indeed I have a pre-installed Suse Enterprise edition. Not chosen for MS Windows this time to gather experience with something different.

    I will open a support case with Novell to deal with this problem. When it is fixed I will make a note on this thread.

    Thanks,
    Philip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •