Results 1 to 4 of 4

Thread: segfault from npviewer

  1. #1
    Join Date
    Oct 2009
    Location
    A place with no mountains
    Posts
    280

    Default segfault from npviewer

    How can I remove npviewer?

    Code:
    [  784.064765] npviewer.bin[2641]: segfault at ff99cd48 ip 00000000ff99cd48 sp 00000000ffae852c error 14
    [ 6316.399677] npviewer.bin[8769]: segfault at ff99cd48 ip 00000000ff99cd48 sp 00000000fff1715c error 14
    [ 6552.586742] npviewer.bin[8896]: segfault at ff99cd48 ip 00000000ff99cd48 sp 00000000fff59d6c error 14
    It seems to be related to nspluginswrapperr, which I would prefer not to use.

    Code:
    uname -a
    Linux linux-j9du 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: segfault from npviewer

    nspluginwrapper is required on _64 machines using the 32 bit flash-player

    If you want to try removing them both and manually installing the _64bit flash-player

    Download here: Adobe Labs - Downloads: Flash Player 10 for 64-bit Linux


    • Extract the plugin, and place a copy of it in /usr/lib64/browser-plugins
    • Restart firefox. Check that firefox sees the plugin by looking in the Add-ons.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Oct 2009
    Location
    A place with no mountains
    Posts
    280

    Default Re: segfault from npviewer

    Quote Originally Posted by caf4926 View Post
    nspluginwrapper is required on _64 machines using the 32 bit flash-player

    If you want to try removing them both and manually installing the _64bit flash-player

    Download here: Adobe Labs - Downloads: Flash Player 10 for 64-bit Linux


    • Extract the plugin, and place a copy of it in /usr/lib64/browser-plugins
    • Restart firefox. Check that firefox sees the plugin by looking in the Add-ons.
    I guess nspluginwrapper is a default part of 11.2 RC 64 bit. I certainly didn't install it.

    However, as a matter of habit, I always install the 64 bit flash player manually. I did this without even realizing the nspluginwrapper was installed.

    Now I'll try removing nspluginwrapper with
    Code:
    # zypper remove nspluginwrapper
    EDIT: success. And my previously installed 64 bit flash still works (as tested on YouTube just now).
    Last edited by MountainX; 06-Nov-2009 at 12:16. Reason: it worked

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: segfault from npviewer

    Great news. You are really getting the hang of it now!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •