Results 1 to 7 of 7

Thread: KDE4 K3b codecs?

  1. #1
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default KDE4 K3b codecs?

    I noticed that, by default, openSUSE 11.2 installs the KDE4 version of K3b as part of the KDE4 desktop. I assumed this meant that the app now included mp3 support via libmad, but it apparently does not, even after installing the normal codecs from Packman. Is it possible to use mp3s in KDE4-K3b, and if not, why is it being used as the default KDE cd burning software in 11.2?
    Dell Inspiron 530 - C2Q@2.4Ghz; 6GB RAM; openSUSE 11.2 x86_64; KDE 4.4.1
    Dell Inspiron 1440 - C2D@2.2Ghz; 4GB RAM; openSUSE 11.2 x86; KDE 4.4.1
    Dell Latitude D531 - AMD Turion X2 64@2.0Ghz; 2GB RAM; Linux Mint 8

  2. #2
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,169

    Default Re: KDE4 K3b codecs?

    It is best to uninstall the opensuse version of k3b and install both the package and codec rpm from packman (which still uses the old name format kde4-k3b)

  3. #3

    Default Re: KDE4 K3b codecs?

    I had the same problem. I had to install the version of k3b from the Packman repo to burn mp3s, there simply wasn't any way to make the version packaged with 11.2 work.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: KDE4 K3b codecs?

    In 11.1 k3b from suse was the same basically as the k3b-codecs from packman so you could mix then.
    In 11.2 it's different ATM at least. Remember Packman is still being Packaged ready for release.
    It's probably best anyway to remove k3b from the default install and add in kde4-k3b and the matching codecs from Packman
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: KDE4 K3b codecs?

    Hi,
    what about openSUSE 11.3? Do you still need to remove the packaged k3b and install the packages from the packman repository?

    Trying to install the k3b-codecs I get a conflict message from YaST Software Manager:
    "k3b-codecs-2.0.1.1-1.pm.2.5.x86_64 requires k3b = 2.0.1, but this requirement cannot be provided"

    Is there any description of the procedure to follow afterwards?
    Would the first option (install k3b and k3b-lang with "vendor change" from packman) be enough here?

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: KDE4 K3b codecs?

    Quote Originally Posted by zois View Post
    Would the first option (install k3b and k3b-lang with "vendor change" from packman) be enough here?
    Yes, changing the vendor to packman is the solution.

  7. #7

    Default Re: KDE4 K3b codecs?

    I tried it out and it works for 11.3:
    Trying to install the k3b-codecs I get a conflict message from YaST Software Manager:
    "k3b-codecs-2.0.1.1-1.pm.2.5.x86_64 requires k3b = 2.0.1, but this requirement cannot be provided"

    Choose the first option (install k3b and k3b-lang with "vendor change" from packman) and the k3b-codecs are available;-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •