Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 11.2rc and poor internet performance

  1. #1
    google01103 NNTP User

    Default 11.2rc and poor internet performance

    dual booting 11.1 and 11.2 x64 kde4.3 and 11.2's
    browsing performance is horrid vrs 11.1's.

    Seeing Opera state "sending request" for 5 seconds
    before anything starts dl'ing and the dl's are also
    much slower and Chromium is no better.

    11.1 and 11.2 has networking configured the same
    (from what I can tell) and I switched 11.2 between
    networkmanager and ifup with no discernible
    difference. Both 11.1 and 11.2 have ipv6 enabled
    and turning off in 11.2 made no diff.

    any ideas?


    --
    openSuse 11.1 x64bit, KDE4.x Factory, Opera weekly

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: 11.2rc and poor internet performance

    I recall reading a bug report that turning off ipv6 on 11.2 in fact did not turn off ipv6. On my Sandbox PC I was able to turn off ipv6 on 11.2 by simply selecting the disable ipv6 upon install. That purportedly DOES work.

  3. #3
    google01103 NNTP User

    Default Re: 11.2rc and poor internet performance

    oldcpu wrote:

    >
    > I recall reading a bug report that turning off

    ipv6 on 11.2 in fact
    > did
    > not turn off ipv6. On my Sandbox PC I was able

    to turn off ipv6 on
    > 11.2 by simply selecting the disable ipv6 upon

    install. That
    > purportedly DOES work.
    >
    >

    yes - seems that ipv6 was the cause though it
    worked fine in 11.1 and was disabled in yast
    (though as reported above not really)

    found this post for resolution
    http://forums.opensuse.org/pre-release-
    beta/424512-11-2-rc-network-problems-yast-repos-
    fetching-etc.html

    thanks,
    --
    openSuse 11.1 x64bit, KDE4.x Factory, Opera
    weekly

  4. #4
    google01103 NNTP User

    Default Re: 11.2rc and poor internet performance

    google01103 wrote:

    > oldcpu wrote:
    >
    >>
    >> I recall reading a bug report that turning off

    > ipv6 on 11.2 in fact
    >> did
    >> not turn off ipv6. On my Sandbox PC I was

    able
    > to turn off ipv6 on
    >> 11.2 by simply selecting the disable ipv6 upon

    > install. That
    >> purportedly DOES work.
    >>
    >>

    > yes - seems that ipv6 was the cause though it
    > worked fine in 11.1 and was disabled in yast
    > (though as reported above not really)
    >
    > found this post for resolution
    > http://forums.opensuse.org/pre-release-
    > beta/424512-11-2-rc-network-problems-yast-

    repos-
    > fetching-etc.html
    >
    > thanks,

    url that works http://tinyurl.com/y9obfxo
    and will quote the solution given:

    "2) KDE 4.3 and others problems with FTP
    Reason was very simple - IPv6. it was used in
    name resolution by KDE libraries.
    To disable IPv6 for KDE place following:

    export KDE_NO_IPV6=true

    in your "/etc/bash.bashrc.local" and restart KDE
    (+ may be kdm, so if you dont know how to do that
    - just reboot)
    If that does not help - we have to disable IPv6
    completely (in my case IPv6 is useless, so I can
    disable it with no doubt)
    Forget all stories about disabling IPv6 in
    /etc/modprobe.d
    IPv6 now compiled into a kernel and no longer a
    module, so /etc/modprobe.d configuration wouldn't
    help.

    Just try to do following (as root) (and don't
    forget to replace "eth0" with name of your
    network interface) :

    sysctl -w net.ipv6.conf.all.disable_ipv6=1
    ifdown eth0
    ifup eth0
    ifconfig | grep inet6

    If output of grep is empty - you've successfully
    disabled IPv6. It will be disabled until you
    reboot. To disable IPv6 permanently add a line to
    /etc/sysctl.conf:

    net.ipv6.conf.all.disable_ipv6 = 1

    reboot and enjoy an OpenSuse 11.2 without
    mysterious network problems."
    --
    openSuse 11.1 x64bit, KDE4.x Factory, Opera
    weekly

  5. #5
    Join Date
    Jul 2008
    Location
    Wisconsin, USA
    Posts
    187

    Default Re: 11.2rc and poor internet performance

    I use this and it works perfectly for me:

    https://bugzilla.novell.com/show_bug.cgi?id=539869

    Append ipv6.disable=1 to your boot parameter either by using yast or edit /boot/grub/menu.lst manually
    openSUSE 11.3 GM + M$ Win Vista HP TX1316au AMD Athlon 64 X2 Mobile TK-55, nVidia GeForce Go 6150

    openSUSE 11.3 GM + M$ Win 7 HP dm-3 AMD Neo X2 L335, ATI Mobility Radeon HD 3200

  6. #6
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Re: 11.2rc and poor internet performance

    It's not encouraging for others to install openSUSE-11.2

  7. #7
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Re: 11.2rc and poor internet performance

    Hope,it will be fixed before final release.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: 11.2rc and poor internet performance

    Quote Originally Posted by colao View Post
    It's not encouraging for others to install openSUSE-11.2
    I think this needs to be put in context. This ipv6 problem does not occur for the majority. In my case, I typically select to disable ipv6 as one of the installation options. And even when I have forgotton, I have not had an ipv6 problem.

    Quote Originally Posted by colao View Post
    Hope, it will be fixed before final release.
    Possibly, but I suspect it will NOT change between RC2 and GM version. Only really blocking problems are fixed between RC2 and GM versions. Hence the work arounds noted in this thread are good to keep in mind for the minority of users who might encounter this anomaly.

  9. #9
    Join Date
    Nov 2009
    Location
    Sweden
    Posts
    50

    Default Re: 11.2rc and poor internet performance

    You guys are awesome! Disabling IP 6 (boot opt) did it for me. I'm completely new to Suse (from Mandriva, Ubuntu), and was so disapointed looking at a nice OS with lot of troubles with the internet connection(s).

    My Opera was not just working bad before disabling: it hanged, took all CPU power.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: 11.2rc and poor internet performance

    Quote Originally Posted by zuchov View Post
    Disabling IP 6 (boot opt) did it for me. I'm completely new to Suse (from Mandriva, Ubuntu), and was so disapointed looking at a nice OS with lot of troubles with the internet connection(s).

    My Opera was not just working bad before disabling: it hanged, took all CPU power.
    Welcome to our forum! Welcome to openSUSE!

    Well done on surfing on the forum and finding the ipv6 answer you needed. Best wishes with your openSUSE experience.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •