Results 1 to 5 of 5

Thread: error while loading shared libraries: libtiff.so.4

  1. #1
    martina_italy NNTP User

    Default error while loading shared libraries: libtiff.so.4

    Hi,
    trying to install this software
    fullanalyze - Project Hosting on Google Code
    I get "error while loading shared libraries: libtiff.so.4: cannot open shared object file: No such file or directory."

    I have a toshiba laptop 32bit that runs opensuse 11.1 with GNOME and I'm not a Linux expert.

    Thank you in advance for any help you can provide,
    Martina

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: error while loading shared libraries: libtiff.so.4

    Quote Originally Posted by martina italy
    Hi,
    trying to install this software
    'fullanalyze - Project Hosting on Google Code'
    (http://code.google.com/p/fullanalyze/)
    I get "error while loading shared libraries: libtiff.so.4: cannot open
    shared object file: No such file or directory."

    I have a toshiba laptop 32bit that runs opensuse 11.1 with GNOME and
    I'm not a Linux expert.

    Thank you in advance for any help you can provide,
    Martina
    Hi
    There is no libtiff.so.4 yet You could try a soft link to
    libtiff.so.3? From a terminal run the following;

    Code:
    sudo ln -s /usr/lib/libtiff.so.3 /usr/lib/libtiff.so.4
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 1 day 14:20, 2 users, load average: 0.28, 0.16, 0.15
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: error while loading shared libraries: libtiff.so.4

    Buongiorno Martina, welcome to the forum.

    Please use yast --> Software Installation and install the libtiff3 package. You may also need the libtiff-devel package if you want to compile an application from source.

  4. #4
    martina_italy NNTP User

    Default Re: error while loading shared libraries: libtiff.so.4

    libtiff3 was already installed, but the soft link to libtiff.so.3 works!
    Thank you very much... I really appreciate your work!

  5. #5

    Default Re: error while loading shared libraries: libtiff.so.4

    Quote Originally Posted by malcolmlewis View Post
    Hi
    There is no libtiff.so.4 yet You could try a soft link to
    libtiff.so.3?
    Doing that is outright stupid. .so.4 has a different ABI than .so.3. That's what the number change indicates. (No, it's not the version number of the project itself, at least not for arbitrary software.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •