Results 1 to 3 of 3

Thread: CentOS/RHEL build requires failure for libpurple-devel

  1. #1

    Default CentOS/RHEL build requires failure for libpurple-devel

    Just trying to build a package, and got it successfully building for openSUSE 11.2 first.

    Then I wanted to make the build service build it for RHEL and CentOS (as I didn't really know what difference this would make, I asked the service to build both).

    The build failed with an expansion error:

    nothing provides libpurple-devel >= 2.3.1

    Now this confuses me, as the Red Hat Enterprise 5/CentOS 5 systems I have certainly have this package:

    RHEL 5.4:

    Name : libpurple-devel
    Arch : i386
    Version : 2.6.3
    Release : 2.el5
    Size : 215 k
    Repo : rhel-x86_64-server-productivity-5
    Summary : Development headers, documentation, and libraries for libpurple
    License : GPLv2+ and GPLv2 and MIT
    Description: The libpurple-devel package contains the header files, developer
    : documentation, and libraries required for development of libpurple
    : based instant messaging clients or plugins for any libpurple based
    : client.

    CentOS 5.4:

    Name : libpurple-devel
    Arch : i386
    Version : 2.6.3
    Release : 2.el5
    Size : 1.1 M
    Repo : installed
    Summary : Development headers, documentation, and libraries for libpurple
    URL : Pidgin, the universal chat client
    License : GPLv2+ and GPLv2 and MIT
    Description: The libpurple-devel package contains the header files, developer
    : documentation, and libraries required for development of libpurple
    : based instant messaging clients or plugins for any libpurple based
    : client.

    So, what are these RHEL/CentOS build machines that they don't have standard packages?

    Cheers,

    John.

  2. #2

    Default Re: CentOS/RHEL build requires failure for libpurple-devel

    $ osc ls -b CentOS:CentOS-5 -r standard -a x86_64 | fgrep libpurple-devel
    libpurple-devel-2.0.2-3.el5.x86_64.rpm
    Perhaps CentOS-5 was released with libpurple-devel 2.0.2 and after release it was updated to 2.6.3?
    Has CentOS "Service Packs" or something similar?

    The thing is the OBS has a copy of CentOS-5 with libpurple 2.0.2... if you think that's wrong comment it in the opensuse-buildservice mailing list.

  3. #3

    Default Re: CentOS/RHEL build requires failure for libpurple-devel

    Quote Originally Posted by RedDwarf View Post
    Perhaps CentOS-5 was released with libpurple-devel 2.0.2 and after release it was updated to 2.6.3?
    Has CentOS "Service Packs" or something similar?

    The thing is the OBS has a copy of CentOS-5 with libpurple 2.0.2... if you think that's wrong comment it in the opensuse-buildservice mailing list.
    Well, I've since discovered that OBS has RHEL 5.1/CentOS 5.1 vs. the current versions, RHEL 5.4/CentOS 5.4.

    RHEL 5.1 released 2007-11-07
    RHEL 5.4 released 2009-09-02

    I have raised a bug to hopefully get RHEL5/CentOS5 updated:

    https://bugzilla.novell.com/show_bug.cgi?id=552468

    I also raised a bug to get RHEL4 updated, as this fails to build my package too. OBS currently has RHEL 4.7 vs the current 4.8 - however in this case RHEL 4.7 _does_ in reality have a new enough libpurple-devel, but this package somehow isn't included in the OSC build config:

    Code:
    $ osc ls RedHat:RHEL-4 -b -r standard -a i586|grep -E "(pidgin|purple)"
    pidgin-1.5.1-1.el4.i386.rpm
    https://bugzilla.novell.com/show_bug.cgi?id=552696

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •