Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: opensuse 11.2 KDE does not autoconnect (always ask for pwd)

  1. #1
    shamaz NNTP User

    Lightbulb opensuse 11.2 KDE does not autoconnect (always ask for pwd)

    Well, I've found the solution but I just wanted to share it...

    The problem is related to the way the KNetworkManager plasmoid works.
    Each time I booted, I had to type either my wpa/wep password (when not using KWallet) either my KWallet password (when using KWallet to remember my network key).
    I'm sorry, but this is not really user friendly . My girlfriend didn't understand why she had to type some password to get 'internet'... Well, you know, with Windows it is 'automatic'

    So now, with the solution... you have to go into System Settings, and on the 'Other' section of 'network & connectivity'.
    Then on the 'connection secrets' tab choose to save 'secrets' in an unencrypted file. (not sure about the exact labels, I don't use the English locale)
    And that's all. (you may also have to disable KWallet)

    Hope that can help someone

    I don't know if it can be considered as an usability bug, but maybe some more explanation can be added somewhere in the UI

  2. #2

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    I am having a similar problem. KNetwork Manager whether using kwallet or not wont connect to my hidden ssid WAP that uses WPA2 Personal. It doesnt even look like it is trying. I open the connection management, add a new wireless connection and provide the ssid and key and click apply then OK but it won't connect for anything. And when I click the plasmoid it shows the name of the network I added but it says insecure next to it. Works fine on Gnome Network Manager. This is on a Thinkpad T61p with a Intel Corporation PRO/Wireless 4965 AG.

  3. #3

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    knetwork seems to have issues like this, its sort of why for my wireless using friends I have them on Gnome or on ubuntu.

  4. #4

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    I had the same problem as kennonk and was able to solve it (at least for now! ) by logging in to the Gnome environment (thanks, TaraIkeda) and connecting to my wireless home network from there.
    Once I did that, I was able to log back in using KDE, and it connected automatically - and quickly!
    So... it seems I wasn't able to configure something (don't know what) in KDE, but was successful in Gnome and the configuration settings "stuck."
    I hope this saves some other folks some time and avoids some of the frustration I was starting to feel!

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    I'm also experiencing this problem. Was working fine in 11.1 but with 11.2 I keep getting prompted for a WPA2 password; it never connects. Unfortunately I don't have GNOME installed nor do I have the space to install it, so I'm dead in the water at this point.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    You can still install the NetworkManager-gnome package via the yast software manager. It will load any dependent packages for you without the complete Gnome DE being required.

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for pwd)

    On 11/14/2009 08:46 PM, DiskCrasher wrote:
    >
    > I'm also experiencing this problem. Was working fine in 11.1 but with
    > 11.2 I keep getting prompted for a WPA2 password; it never connects.
    > Unfortunately I don't have GNOME installed nor do I have the space to
    > install it, so I'm dead in the water at this point.


    Have you selected "Manage Connections" and then done a edit on the connection
    you want? NM cannot update the database from the screens that popup when a
    connection fails.

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    I think I found the issue. I was using KWallet to store the WPA2 password. So I quit KWallet and then tried to reconnect again and it worked!

  9. #9

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    It's very frustrating . Really!! Until version 11.0 and KDE 3.5, setting up a wireless connection was very easy. But since version 11.1 and KDE 4.0, it's a pain (and this when it works!).

  10. #10
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: opensuse 11.2 KDE does not autoconnect (always ask for p

    Frustrating indeed. I suppose this is one example why Linux hasn't made inroads on the desktop.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •