Results 1 to 5 of 5

Thread: Enabling compiz

  1. #1

    Default Enabling compiz

    Apologies if this request is somewhat simple, but I'm still struggling up the Linux learning curve!

    After much toil, I have got my graphics card working properly (I think) and can use the KWin desktop effects.
    I want to use Compiz instead of KWin.
    It seems this is installed properly, I can enter simple-ccsm and ccsm, but I can't figure out how to use any of the effects.
    Do I need to do something to enable Compiz and disable KWin or is it a more complex issue?

    My computer is a Toshiba A100-920, with an ATI Radeon Mobility X1400 graphics chip, running the fglrx drivers.
    I'm using opensuse 11.1 64bit and KDE4.1.3

    Any help would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Enabling compiz

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Enabling compiz

    Hi,

    If you have compiz installed correctly for your version of KDE, then to have it activate at every start, open up Configure Desktop (Personal Settings), then under the Personal Category choose Default Applications. Click the Window Manager category then choose Use a different window manager. Click the drop down and choose Compiz (not compiz custom).

    Log out then log back in to make sure it works.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4

    Default Re: Enabling compiz

    Thanks Ian.

    I tried logging out and back in and got a corrupted screen for some reason. I rebooted and Compiz seems to be working fine.
    After trawling through a load of compiz posts, I was convinced it was going to be something hard to fix, now I feel a bit silly for asking!!!
    Just have to figure out how to use all the effects now!

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Enabling compiz

    Glad you got it working!

    Here's a very brief reference tool for what each plugin does.

    PluginsMain - Compiz Wiki

    You can also click into each brief plugin description to get a better description of it and the options each plugin has; usually with a representation on the right side and sometimes a picture on the left.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •