Results 1 to 7 of 7

Thread: Broken OpenGL compositing after the latest update?

  1. #1

    Default Broken OpenGL compositing after the latest update?

    I just performed zypper up (11.2RC2) and after restart all I got is a black screen (GUI is automatically started). Removing ~/.kde* "fixed" the problem. Luckily, desktop effects are turned off by default. Turning it on with OpenGL compositing type fails with the following message:

    Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

    Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.

    However, RenderX works.

    Has anyone experienced the same behaviour?
    --
    Davor Čengija

  2. #2
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Broken OpenGL compositing after the latest update?

    I reinstalled my nvidia driver and all is good.

    There were several updates to X11, often when X11 is updated you need to reinstall video drivers.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Broken OpenGL compositing after the latest update?

    No it all worked fine for me. But it always seems to with this Laptop. I'm dreading the day when I have to replace it.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Broken OpenGL compositing after the latest update?

    I reinstalled nvidia driver, and still no luck - opengl doesn't work, renderx does. Any ideas? How can I see which packages were updated lately?
    --
    Davor Čengija

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Broken OpenGL compositing after the latest update?

    /var/log/zypp/history

    scroll down to the end
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    Srbija
    Posts
    221

    Default Re: Broken OpenGL compositing after the latest update?

    I had a similar problem, my compositing was on and after I read this, restart disabled nvidia driver.
    Reinstall fixed it. There should be a warning about this to reinstall the driver
    VERBA VOLANT, SCRIPTA MANENT

  7. #7

    Default Re: Broken OpenGL compositing after the latest update?

    Ah, quite strange - after yet another restart, OpenGL compositing works.

    Zypper's history log shows that several X11/sax2 related packages were updated, which probably caused the problem.
    --
    Davor Čengija

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •