Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Change localization settings

  1. #1

    Default Change localization settings

    Hi there,

    I'm running an openSUSE fresh installation and most of the things are running fine, there are however some settings that are not the way I want them, and I can't seem to change them.

    This is what I want:
    - Language of everything set US English
    - Keyboard is US English
    - Date, time, numeric, monetary and all other locale settings to dutch, except warning, errors, etc.

    To configure this I opened the Yast sysconfig editor and changed all settings to nl_NL.UTF-8:
    • RC_LC_MESSAGES="nl_NL.UTF-8"
    • RC_LC_CTYPE="nl_NL.UTF-8"
    • RC_LC_COLLATE="nl_NL.UTF-8"
    • RC_LC_TIME="nl_NL.UTF-8"
    • RC_LC_NUMERIC="nl_NL.UTF-8"
    • RC_LC_MONETARY="nl_NL.UTF-8"
    • RC_LC_PAPER="nl_NL.UTF-8"

    which shows in the language file:

    Code:
    sjoerd@ws0052:~> cat /etc/sysconfig/language | grep '^[A-Z]'
    INPUT_METHOD=""
    RC_LANG="en_US.UTF-8"
    RC_LC_ALL=""
    RC_LC_MESSAGES="nl_NL.UTF-8"
    RC_LC_CTYPE="nl_NL.UTF-8"
    RC_LC_COLLATE="nl_NL.UTF-8"
    RC_LC_TIME="nl_NL.UTF-8"
    RC_LC_NUMERIC="nl_NL.UTF-8"
    RC_LC_MONETARY="nl_NL.UTF-8"
    RC_LC_PAPER="nl_NL.UTF-8"
    ROOT_USES_LANG="ctype"
    AUTO_DETECT_UTF8="no"
    INSTALLED_LANGUAGES=""
    But, even after a reboot, the locale does not change:
    Code:
    sjoerd@ws0052:~> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    I do have the specific locale:
    Code:
    sjoerd@ws0052:~> ls -l /usr/lib/locale/nl_NL.utf8/
    total 1232
    -rw-r--r--   1 root root    144 2009-09-08 18:37 LC_ADDRESS
    -rw-r--r-- 141 root root 952222 2009-09-08 18:30 LC_COLLATE
    -rw-r--r-- 192 root root 256444 2009-09-08 18:30 LC_CTYPE
    -rw-r--r--   1 root root    355 2009-09-08 18:37 LC_IDENTIFICATION
    -rw-r--r-- 257 root root     23 2009-09-08 18:30 LC_MEASUREMENT
    drwxr-xr-x   2 root root   4096 2009-10-26 09:17 LC_MESSAGES
    -rw-r--r--   4 root root    294 2009-09-08 18:35 LC_MONETARY
    -rw-r--r-- 125 root root     62 2009-09-08 18:31 LC_NAME
    -rw-r--r--  39 root root     54 2009-09-08 18:31 LC_NUMERIC
    -rw-r--r-- 254 root root     34 2009-09-08 18:30 LC_PAPER
    -rw-r--r--   4 root root     49 2009-09-08 18:35 LC_TELEPHONE
    -rw-r--r--   3 root root   2366 2009-09-08 18:37 LC_TIME
    I tried the following things to change the behaviour:
    • Changed the RC_LC_ALL to UTF-8
      This changed everything including the language of programs like Yast, which is just exactly what I don't want.
    • Changed the UTF-8 to utf8
      This broke even RC_LC_ALL setting


    There is something going terribly wrong, does anyone know what?

    Kind regards,
    Sjoerd

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,795

    Default Re: Change localization settings

    You must have changed something at installation because English is the default.

    Unix/Linux is a multi user system. This means (among other things) that when you change these values on the system level, the are only changed for the system level. Not for the individual user, because every user may have hers/his own likings. When you want to change for a users desktop that can be done in the the GUI. I am an KDE user, but I bet Gnome has something like that. In the KDE main menu (Kicker) there is something like Configuration centre/ Desktop settings (language dependent ) and there you find icons with a flag, etc.

    HTH.

    Edit: I see this is your first post. Welcome to the forums. Welkom Sjoerd.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Change localization settings

    Quote Originally Posted by hcvv View Post
    You must have changed something at installation because English is the default.


    Edit: I see this is your first post. Welcome to the forums. Welkom Sjoerd.
    On install it's possible to pick 'Nederlands', which is what Sjoerd did. This brings all LC values to dutch standards.


    Now, this is what he wants, but the desktop language. For years now it has been possible to install multiple languages for the desktops, even Frysian, Sjoerd. Play around with KDE4's Configure Desktop (systemsettings)- Regional settings, and you'll find out.

    Ennuh......welkom !!
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Change localization settings

    Distinguish between the YaST settings which are intended to match your hardware to the system - so you only set the keyboard to US in YaST if you have a US keyboard layout - and the software settings in Gnome and KDE which allow each user to change the way the keyboard responds to suit their needs.

  5. #5

    Default Re: Change localization settings

    Hey everyone,

    I did not select Nederlands as language during installation. I selected English (US) during the installation for language and for keyboard because that's the way I want it.

    The main things I want is this:
    - I want the date displayed in DD MM instead of MM DD
    - I want money displayed as 10,00 instead of 10.00
    - I want the default paper size set to A4 instead of letter, but I could live with that one.

    Now, as I understand I've been configuring the system settings while I should have been configuring the user settings. The thing is, Yast only lets me configure the language and the keyboard for as far as I know and they are set the way I want them (to US English).

    So now I've learned something more I can redefine my question, how can I set the three items above to the desired settings for my user account in Gnome.

    Thanx, also for the warm welcomes

  6. #6
    palladium NNTP User

    Default Re: Change localization settings

    when logged in as yourself, isn't there something called a "control
    center" (or something like that) in the menu, and in or near there is
    a "personal settings" and/or "configure desktop"??

    the date and money will be found under "localization" or "regional &
    accessibility"..

    i think you set the default paper in the printer set up...BUT, in (for
    example) OpenOffice.org i think you also have to set it there, and
    _maybe_ in each program you wanna print from...(well, if you use
    nothing but "Gnome applications" they may all be able to be set at one
    place....

    don't know...haven't used Gnome in years..
    --
    palladium
    Have a lot of fun..

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Change localization settings

    Quote Originally Posted by Sjoerdhooft View Post
    I did not select Nederlands as language during installation. I selected English (US) during the installation for language and for keyboard because that's the way I want it.
    I think you have misunderstood what I wrote; during the installation you select the keyboard that matches your hardware. If you have a Dutch keyboard and have selected US during installation, you will completely confuse openSUSE.

    During installation, you select the keyboard layout that matches your hardware. After you have completed the installation you adjust the way the keyboard responds to your keystrokes by installing the appropriate software keyboard.

    If the selection in YaST does not match the hardware of your keyboard, you need to go into YaST and change it. Then you can change the software layout in Gnome.
    Last edited by john_hudson; 04-Nov-2009 at 13:25. Reason: Clarification

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,795

    Default Re: Change localization settings

    Quote Originally Posted by john_hudson View Post
    I think you have misunderstood what I wrote; during the installation you select the keyboard that matches your hardware. If you have a Dutch keyboard and have selected US during installation, you will completely confuse openSUSE.

    During installation, you select the keyboard layout that matches your hardware. After you have completed the installation you adjust the way the keyboard responds to your keystrokes by installing the appropriate software keyboard.

    If the selection in YaST does not match the hardware of your keyboard, you need to go into YaST and change it. Then you can change the software layout in Gnome.
    I am sorry John, but imo it is not about his keyboard. We use the same keyboard as you. It is about is Localisation: date/time fornat, valuta character €, decimal sign , instead of ., paper format A4, ....

    In KDE that is ver easy. You start your desktop configuration (has nothing to do with YaST Sjoerd) and then to localisation (icon with flag) and then you find everything. You can choose a Language,a nd when this langige isn;t there you can install it (though this asked for tyhe root password). When you have chosen the language, most of the other parameters will be set to what we dutch like, but you can always change them individualy. The only thing is that I use KDE and can't tell Sjoerd how this is done in Gnome. But it can't be that different!.

    And yes, keyboard choosing is part of it, but I live happy with English US. Some dutch might choose Portugese Brazil (surprise).
    Henk van Velden

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Change localization settings

    To add: there are dutch keyboards, They reside on typewriters and have never been very common. We dutch people always have to set our keyboard to US, since we use US keyboards,

    Installing Gnome right now, to see if I can find this.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Change localization settings

    No result yet, I'll ask around tomorrow. Did not know this could not be done in Gnome like in KDE
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •