Results 1 to 5 of 5

Thread: kernl and kernel source. Unable to install VMWare tools

  1. #1

    Default kernl and kernel source. Unable to install VMWare tools

    Hallo:

    I'm testing OpenSuse 11.1. So I'm running it on VMWare 1.0.9.

    But I'm unable to install vmware tools.

    When running vmware-config.pl is says I have to install C headers files that match my running kernel.
    So I've installed kernel-source. But my kernel is:
    root> uname -r
    2.6.27.7-9-pae

    and kernel source is:
    root> rpm -qa | grep source
    2.6.27.37-0.1.1

    so wmware tools say they are different.

    How can I install kernel-source for my kernel (or update kernel to that source)?
    Thanks
    Last edited by torcaz99; 03-Nov-2009 at 04:27. Reason: bad title

  2. #2

    Default Re: Unable to install VMWare tools in OpenSuse 11.1

    Quote Originally Posted by torcaz99 View Post
    How can I install kernel-source for my kernel (or update kernel to that souce)?
    Thanks
    The more logical way would be to update your kernel to that version and reboot.

  3. #3

    Default Re: kernl and kernel source. Unable to install VMWare tools

    I've found the kernel-source in the installation DVD.

    But it returns compilation errors with pae kernel.

    Nevertheless, I've been able to install vmware tools.

    Thanks

  4. #4

    Default Re: kernl and kernel source. Unable to install VMWare tools

    Something is not clear to me.
    You say you are testing opensuse inside VMWare 1.0.9. I suppose that is the Server version of VMWare.

    But to install VMWare tools you need to activate this option in one of the VMWare menu's and than a virtual disk will be mounten from where you can install the shell script as root.

    But you mention vmware-config.pl
    That is the configuration script to configure the VMWare software which is running under linux, but in this case you are already running VMWare with Linux inside it. So are you running this VMWare on another Linux distro ?

    It's really not clear and to me it seems that you are mixing two things.

  5. #5

    Default Re: kernl and kernel source. Unable to install VMWare tools

    Yes, you are right.

    I'm a Kubuntu 8.04 user. And i'm thinkig about migrating to OpenSuse.

    I use VMWare Server 1.0.9.

    But now, after installing kernel source, compilation was fine and it runs...

    Thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •