Results 1 to 2 of 2

Thread: Exim Compile Error

  1. #1

    Default Exim Compile Error

    Hi i am trying to compile exim with mysql support included,

    but when i do a make i get the following error.

    Code:
    make[2]: Entering directory `/downloads/exim-4.69/build-Linux-i386/auths'
    gcc auth-spa.c
    gcc b64decode.c
    gcc b64encode.c
    gcc call_pam.c
    gcc call_pwcheck.c
    gcc call_radius.c
    gcc check_serv_cond.c
    gcc cram_md5.c
    gcc cyrus_sasl.c
    gcc dovecot.c
    gcc get_data.c
    gcc get_no64_data.c
    gcc md5.c
    gcc plaintext.c
    gcc pwcheck.c
    gcc sha1.c
    gcc spa.c
    gcc xtextdecode.c
    gcc xtextencode.c
    ar cq auths.a
    ranlib auths.a
    make[2]: Leaving directory `/downloads/exim-4.69/build-Linux-i386/auths'
     
    make[1]: *** No rule to make target `lookups/lookups.a', needed by `exim'.  Stop.
    make[1]: Leaving directory `/downloads/exim-4.69/build-Linux-i386'
    make: *** [go] Error 2
    could someone please give some advise,

    I am running openSuSE 11.1, with exim 4.69

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Exim Compile Error

    Quote Originally Posted by sayajin
    Hi i am trying to compile exim with mysql support included,

    but when i do a make i get the following error.


    Code:
    --------------------

    make[2]: Entering directory
    `/downloads/exim-4.69/build-Linux-i386/auths' gcc auth-spa.c
    gcc b64decode.c
    gcc b64encode.c
    gcc call_pam.c
    gcc call_pwcheck.c
    gcc call_radius.c
    gcc check_serv_cond.c
    gcc cram_md5.c
    gcc cyrus_sasl.c
    gcc dovecot.c
    gcc get_data.c
    gcc get_no64_data.c
    gcc md5.c
    gcc plaintext.c
    gcc pwcheck.c
    gcc sha1.c
    gcc spa.c
    gcc xtextdecode.c
    gcc xtextencode.c
    ar cq auths.a
    ranlib auths.a
    make[2]: Leaving directory
    `/downloads/exim-4.69/build-Linux-i386/auths'
    make[1]: *** No rule to make target `lookups/lookups.a', needed by
    `exim'. Stop. make[1]: Leaving directory
    `/downloads/exim-4.69/build-Linux-i386' make: *** [go] Error 2

    --------------------


    could someone please give some advise,

    I am running openSuSE 11.1, with exim 4.69
    Hi
    You could grab the 'factory' version here and rebuild that?
    http://software.opensuse.org/search?...1&q=exim-mysql
    Code:
    rpmbuild --rebuild exim-mysql-4.69-21.3.src.rpm
    Then install manually.

    Else unpack the src rpm and have a look at the spec file and patches....

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 10:58, 2 users, load average: 0.18, 0.13, 0.10
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •