Results 1 to 6 of 6

Thread: Intel GM45 resolution problem suse 11.1

  1. #1
    piekar294 NNTP User

    Default Intel GM45 resolution problem suse 11.1

    Hi,

    i can set 1366x768 resolution in Yast, but monitor did not aplay changes. There is always 800x600 resolution set. In windows 1366x768 resolution is working, so monitor is ok.

    Here is my xorg.conf
    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-11-03T10:05:22+0100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "glx"
      Load         "dbe"
      Load         "extmod"
      Load         "freetype"
      Load         "dri"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      Driver       "synaptics"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Emulate3Buttons" "on"
      Option       "HorizScrollDelta" "0"
      Option       "InputFashion" "Mouse"
      Option       "Name" "Synaptics;Touchpad"
      Option       "Protocol" "explorerps/2"
      Option       "SHMConfig" "on"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[3]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "ImPS/2 Generic Wheel Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      DisplaySize  293 164
      HorizSync    30-40
      Identifier   "Monitor[0]"
      ModelName    "Unknown"
      Option       "DPMS"
      Option       "PreferredMode" "1366x768"
      VendorName   "Unknown"
      VertRefresh  50-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
        Virtual    3840 1200
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "Mobile Intel GM45 Express Chipset"
      Driver       "intel"
      Identifier   "Device[0]"
      Option       "monitor-LVDS" "Monitor[0]"
      Screen       0
      VendorName   "Intel"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      InputDevice  "Mouse[3]" "SendCoreEvents"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection
    my graphics is Intel GM45.
    Suse is just after installation and updates.

    Someone have any ideas?

  2. #2

    Default Re: Intel GM45 resolution problem suse 11.1

    Hi piekar294,
    one of my friends has a dell vostros 1520 with the same graphic card.
    He also can not really get the card working. Low resolution and sometimes even some display errors (on login in kde).

    I think this card (GM45) is not supported by the kernel provided by opensuse 11.1 maybe it will work with 11.2

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Intel GM45 resolution problem suse 11.1

    I think this card (GM45) is not supported by the kernel provided by opensuse 11.1 maybe it will work with 11.2
    Reply With Quote
    Yes, hopefully openSUSE 11.2 has a working intel driver. It would be nice to read working accounts of intel hardware with widescreen displays reported here.

    The Xorg intel driver seems to have problems with some intel graphics and display hardware. It appears to be the result of a well known bug if you search for "intel xorg 1366 768" and similar.

    I remember a similar thread here:

    stretched screen - openSUSE Forums

    All I can suggest is trying a manual modeline as outlined (with the "Device" options to turn off EDID and DDC also explained in thread). I don't have this chipset, so I can't test or confirm.

  4. #4

    Default Re: Intel GM45 resolution problem suse 11.1

    I convinced my friend to test the life cd of opensuse 11.2 rc2
    It worked great! No display errors, right resolution and even dual head worked out of the box.

    So you have just to be patient some days :-)

  5. #5
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Intel GM45 resolution problem suse 11.1

    That's not entirely my experience with Intel video/11.2 (on two machines now) but with a little bit of fiddling it usually works in the end. On one machine, setting the VGA mode on the *first installer page* did what no amount of fiddling with Sax2 after installation could, that is set a resolution other than 800x600. One the other machine, repeated CTRL-ALT-BCKSP eventually produced a "sticky" resolution after several relapses into 800x600 after a correct (widescreen) start. Make of that what you will, but it IS an improvement on 11.1 no doubt...
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  6. #6

    Default Re: Intel GM45 resolution problem suse 11.1

    I've installed the actual openSUSE 11.2 (64bit) on my DELL Inspirion E6500 with the GM45 Chipset.

    On a docking station is following display pluged in:
    MAX Belinea B2485S1W (WUXGA) 24,1

    If i start sax, the display is correctly indentified.

    But it's the same problem as above. The possible resolution of
    1920x1200 can't be used. I don't know what I can do that this would work fine.

    Which additional information would be helpful?

    kind regards
    Jochen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •