Results 1 to 2 of 2

Thread: Virtualbost Guestadd and foreign keyboard problem

  1. #1

    Default Virtualbost Guestadd and foreign keyboard problem

    Hello,

    I have installed an openSUSE 11.1 guest with KDE 3.5 in an openSUSE 11.1 host with VirtualBox 3.08 (and 3.10). Everything was ok until the installation of the guestadd: from there our (swiss french) keyboard does not work in the KDE environment, still us layout. In runlevel 3 the swiss kb is ok. If I try to reselect the swiss kb from inside KDE after rebooting there is no kb at all.
    The swiss kb works well within the guest without the VB guestadd.
    Any suggestion ?

  2. #2

    Default Re: Virtualbost Guestadd and foreign keyboard problem

    Workaround: Edit the file /etc/X11/xorg.conf and modify the input section following the regular file.

    For the swiss kb, the result is:

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "ch"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "fr"
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •