Results 1 to 5 of 5

Thread: Clock Setting Problem

  1. #1
    Join Date
    Nov 2009
    Location
    New Delhi, India
    Posts
    268

    Default Clock Setting Problem

    Open SUSE 11.2 Milestone -
    I have installed Dual Boot (through Grub), Windows Vista and Linux (now Open Suse 11.2 Milestone)

    I have run into a problem with the clock. Under environment, I have set the hardware clock time to local time, Time Zone to (Asia/Kolkata) and the Default Time Zone also to Asia/Kolkata. Each time I boot in the clock goes back by 5 Hrs 30 min.

    My observations are:

    a) UTC off (i.e. hardware clock set to local time, Time Zone (Asia Kolkata) and default Time Zone any the clock goes slow by 5:30 Hrs.

    b) Hardware clock set to -u, the clock goes ahead by 11:00 Hrs.

    c) A check of the boot log shows the point at which the clock is being reset while booting :
    <notice -- Oct 30 21:54:50.548956000> service boot.clock startSet System Time to the current Hardware Clockdone
    <notice -- Oct 30 16:24:50.704945000> service boot.clock done
    The command comes from the file etc/boot.d/K02boot.clock.

    There is obviously a bug in this file or one of the files it calls up.

    Makes no difference whether I am on line (Broad Band) or operating as stand alone.

    At the moment I resort to resetting the time each time I start SUSE 11.2.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Clock Setting Problem

    Welcome to the forum !!!!

    First: there should be some setting to get it right, better is to use NTP. NTP can be configured from Yast, and syncs your system's time from a time-server.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,334
    Blog Entries
    15

    Default Re: Clock Setting Problem

    Quote Originally Posted by PrakashC
    Open SUSE 11.2 Milestone -
    I have installed Dual Boot (through Grub), Windows Vista and Linux (now
    Open Suse 11.2 Milestone)

    I have run into a problem with the clock. Under environment, I have
    set the hardware clock time to local time, Time Zone to (Asia/Kolkata)
    and the Default Time Zone also to Asia/Kolkata. Each time I boot in the
    clock goes back by 5 Hrs 30 min.

    My observations are:

    a) UTC off (i.e. hardware clock set to local time, Time Zone (Asia
    Kolkata) and default Time Zone any the clock goes slow by 5:30 Hrs.

    b) Hardware clock set to -u, the clock goes ahead by 11:00 Hrs.

    c) A check of the boot log shows the point at which the clock is being
    reset while booting :
    “<notice -- Oct 30 21:54:50.548956000> service boot.clock startSet
    System Time to the current Hardware Clockdone
    <notice -- Oct 30 16:24:50.704945000> service boot.clock done”
    The command comes from the file etc/boot.d/K02boot.clock.

    There is obviously a bug in this file or one of the files it calls up.

    Makes no difference whether I am on line (Broad Band) or operating as
    stand alone.

    At the moment I resort to resetting the time each time I start SUSE
    11.2.
    Hi and welcome to the forum

    What milestone, this was a known bug from a few milestones ago.
    http://forums.opensuse.org/pre-relea...s-a7k-esp.html

    Run mkinitrd as root user and all should be fine.

    You could look at installing RC2 or wait until next week for the
    release.....

    PS: since it's a pre-release/beta you should post issue in
    http://forums.opensuse.org/pre-release-beta/

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 10:41, 2 users, load average: 0.02, 0.06, 0.11
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  4. #4
    Join Date
    Nov 2009
    Location
    New Delhi, India
    Posts
    268

    Default Re: Clock Setting Problem

    Sorry mkinitrd doesnt solve the problem.

    PrakashC

  5. #5
    Join Date
    Nov 2009
    Location
    New Delhi, India
    Posts
    268

    Default Re: Clock Setting Problem

    I had been resigned to live with the clock problem till the Final Release (in a few day?). However, yesterday, I ran the online update and noticed that one of the packages updated was mkinitrd. Obviously the next step was to run mkinitrd as root. And that did the trick. Thanks.

    PrakashC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •