Results 1 to 7 of 7

Thread: Gnome compiz trying to get working

  1. #1

    Default Gnome compiz trying to get working

    Hello,

    I have OpenSuSE 11.0 with a NVIDIA 8600 GTS card working with the NVIDIA drivers setup in TwinView mode.

    I can run compiz and everything works except the window borders disappear. I saw one post (I can't find it now) that says change a setting for metacity but when I did that then compiz wouldn't start.

    I've seen posts that say start emerald and others saying it is no longer supported so I am not sure what's best there but when I tried to start it I got an error.

    As a side note (not sure if this is relevent), when I tried "gnome --version" I got these errors:
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.

    Any help appreciated.
    Reg.

  2. #2
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,859
    Blog Entries
    20

    Default Re: Gnome compiz trying to get working

    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Gnome compiz trying to get working

    I've been through those but as it happens after a few days break, tweaks on the server and so on I found one suggest that works which is this: "Try running compiz-decorator --replace"

    This is a good start but it's only a band-aid solution. Do you have any idea on how to track down the root cause or a proper fix?

    Maybe there's a compiz script that's called that I could modify, any ideas? I did a "grep" through /etc/ for compiz-decorator but nothing came up.

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Gnome compiz trying to get working

    Hi,

    What version of compiz are you using, and what window decorator are you trying to use?

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5

    Default Re: Gnome compiz trying to get working

    Compiz is 0.8.2-162.1 (x86x64...this is a 64bit computer)

    Sorry, how do I figure out which decorator I am trying to use?

  6. #6
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,922
    Blog Entries
    15

    Default Re: Gnome compiz trying to get working

    Quote Originally Posted by Reg gie
    Compiz is 0.8.2-162.1 (x86x64...this is a 64bit computer)

    Sorry, how do I figure out which decorator I am trying to use?
    Hi
    As pointed out by caf4926 in his links, have you tried;
    Code:
    No window decoration
    * rm -rf ~/.config/compiz and restart compiz. This will reset
    compiz to default settings.
    * To fix your compiz window decorations (titlebars) with an nVidia
    graphics card, run sudo nvidia-xconfig --add-argb-glx-visuals -d
    24, then restart X.
    * Try running compiz-decorator --replace & manually from the shell
    or Alt+F2
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 2:34, 2 users, load average: 0.07, 0.14, 0.10
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Gnome compiz trying to get working

    Use the fusion-icon to see which decorators are present. I'm not sure how it is in Gnome but with KDE I use emerald as the decorator. In which case your problem can be solved by opening up the CompizConfig Settings Manager (CCSM) and making sure the Window Decoration plugin is active. Then click into it and next to Command erase what's in there and replace it with:

    Code:
    emerald --replace
    Then enable desktop effects and see if that helps.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •