Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: problem updating

  1. #1

    Question problem updating

    hello, I just installed OpenSuse 11.2 RC on my PC, new to this whole Linux thing so I'm sorry if the question seems a bit "noob", everything went throu just fine, exept 1 lil problem, I can not update, It seems like the Repo's are wrong, so I was wondering, wich one are the actual good repos for 11.2 ? Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: problem updating

    This is what it says: a release candidate; lots of things, like the repos from which you will eventually be able to update, have not yet been finalised.

  3. #3

    Exclamation Re: problem updating

    So I even try to add another repo with zypper and this is what i get:
    xxxx@linux-p0vh:~> sudo zypper addrepo http://packman.unixheads.com/suse/11.2/Packman.repo
    Failed to download /suse/11.2/Packman.repo from Index of /
    Abort, retry, ignore? [a/r/i/?] (a): a

    Problem accessing the file at the specified URI:
    [AbstractCommand.cc:195] URI=http://packman.unixheads.com//suse/11.2/Packman.repo
    Please check if the URI is valid and accessible.

    I can access and even see the .repo file, but apparently suse can't. Am I doing something wrong or my release is not able to Update at all?

    Thanks in advance.

  4. #4

    Thumbs down Re: problem updating

    I even tried the "Wine" repo and it say the same thing... I have access to the INTERNET and can download stuff throu BitTorrents, what its goin on? I'm goin insane here

  5. #5
    spyderpride NNTP User

    Default Re: problem updating

    Try using yast to add repositories.

    Also post the output of zypper lr -d and someone could probably help you more easily. For instance, here is mine (you do not need the KDE 4.3.2 ones, other than that I just have stock repos and packman):

    1 | KDE_4.3.2 | KDE 4.3.2 | Yes | Yes | 95 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.2/ |
    2 | KDE_4.3.2_Community | KDE 4.3.2 Community | Yes | Yes | 120 | rpm-md | http://download.opensuse.org/reposit...E_11.2_KDE_43/ |
    3 | ftp.skynet.be-factory | Packman Repository | Yes | Yes | 90 | rpm-md | http://ftp.skynet.be/pub/packman/suse/factory/ |
    4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...11.2/repo/oss/ |
    5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...11.2/repo/oss/ |
    7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...11.2/repo/oss/ |
    8 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.2/


    I'm also fairly new to opensuse, but I've been using ubuntu since feisty. Just figured I'd try to help get the ball rolling on solving your problem .

  6. #6

    Question Re: problem updating

    Ok, do I tried to add those repos, and when i get to puch "OK" at the final screen I get this msg:

    ERROR
    Download failed:
    Failed to download /repodata/repomd.xml.asc from Index of /pub/packman/suse/factory
    History:
    - [AbstractCommand.cc:195] IRI=http://ftp.skynet.be/pub/packman/suse/factory/repodata/repomd.xml.asc
    OK

    So I can't even add any Repos, and I dont have any, 'cause I delete them, since the ones that were there I tho were wrong.

    Any ideas?

    Thanks.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: problem updating

    You have two choices: wait until after the release of 11.2 or re-install 11.1; there is no point struggling with repos at this point unless you are bug-hunting in which case you should be reporting things to Bugzilla and not here.

  8. #8

    Default Re: problem updating

    I installed 11.2 official release, and encountered same problem.

  9. #9
    michaeltrittipo NNTP User

    Default Re: problem updating

    I am encountering the same behavior. I did an inplace upgrade from 11.1 to 11.2, and the error messages I see are (depending whether it's yast or the update applet that complains):

    Error: PackageKit Error repo-not-available. Failed to download /content from
    Index of /distribution/11.2/repo/non-oss

    or

    Download failed:
    Failed to download /repodata/repomd.xml.asc from http://download.opensusse.org/update/11.2/
    [AbstractCommand cc:195] URI=http://download.opensuse.org/update/11.2/repodata/repomd.xml.asc

    or in the oss and non-oss repositories, not getting repomd.xml (without the .asc extension), with a slight change in wording: "Can't provide /repodata/repomd.xml" and "Valid metadata not found at specified URL(s)."

    Using a browser, I can see /repodata/repomd.xml down the oss and non-oss paths (http://download.opensuse.org/update/11.2/repo/[oss|non-oss].

    I'd welcome any suggestions. If need be, I'll backup my data off the notebook, then do a fresh install of 11.2 instead of an upgrade.

    Fwiw, I'm trying this across a wireless connection that is working fine for the browsers and e-mail clients. But when telling yast to configure the repositories, one error does suggest that the repo server is unavailable or unaccessible. Does the updating look for an internet path anywhere different than the browsers and email do?

  10. #10

    Default Re: problem updating

    Quote Originally Posted by neowesa View Post

    ERROR
    Download failed:
    Failed to download /repodata/repomd.xml.asc from Index of /pub/packman/suse/factory
    History:
    - [AbstractCommand.cc:195] IRI=http://ftp.skynet.be/pub/packman/suse/factory/repodata/repomd.xml.asc
    OK
    Hello folks!
    I have just been fresh installing 11.2 and when it came to test the internet connection, then update the repos and do the online updates, suddenly I was receiving similar error messages and nothing worked anymore.
    YAST could not find any of the repositories, although when browsing to them with a internet browser from another machine, I could find everything just fine.

    After doing a lot of debugging I could finally solve the problem: I am having a gateway server who is running as "unified-thread-management"-server ("Endian Firewall - community edition"), e.g. as a firewall, which is filtering incoming and OUTGOING traffic, and in addition is working as a HTTP-proxy.
    YAST seems to be making some http-filetransfers via TCP/3080 (god knows why) and somehow everything got stuck in my transparent HTTP-proxy. When I added the IP of the machine to the "Bypass transparent proxy" setting, suddenly everything worked like a charm.

    Please feedback, if this applies to you, too!

    Tomakos

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •