Results 1 to 2 of 2

Thread: Skype and shared libraries libasound.so.2

  1. #1
    Join Date
    Jul 2008
    Location
    France
    Posts
    24

    Default Skype and shared libraries libasound.so.2

    Hello,

    I have an old Creative Labs Sound Blaster PCI128 and after the new installation of the 11.1 x86_64 version the sound was creepy. So I downloaded and re-compiled alsa-driver, libs, utils, oss etc for Creative AudioPCI ES1371+ .
    Well, the sound card works just fine. BUT, Skype refuses to run giving the following error message:

    skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

    Actually, the both modules libasound.so.2 do present in the /usr/lib and /usr/lib64.

    However,
    1) "rpm -aq | grep alsa-lib" gives empty string.

    2) "ldd /usr/bin/skype | grep not" gives
    libasound.so.2 => not found


    3) "ldd /usr/bin/skype" gives

    linux-gate.so.1 => (0xffffe000)
    libasound.so.2 => not found
    libXv.so.1 => /usr/lib/libXv.so.1 (0xf7f3c000)
    libXss.so.1 => /usr/lib/libXss.so.1 (0xf7f38000)
    libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf7ecf000)
    libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf7e8c000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf7e48000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf755e000)
    etc...


    Can someone give me a clue how to repair skype ?
    Box: 2.6.34.7-0.3-default #1 SMP x86_64 GNU/Linux | SUSE 11.3 | KDE 4.4.4
    TYAN Thunder S2895 K8WE | 2x AMD Opteron 275 | 2x nVidia 9500GT | 6GB RAM

  2. #2
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Skype and shared libraries libasound.so.2

    Quote Originally Posted by ket_nn View Post
    Hello,

    I have an old Creative Labs Sound Blaster PCI128 and after the new installation of the 11.1 x86_64 version the sound was creepy. So I downloaded and re-compiled alsa-driver, libs, utils, oss etc for Creative AudioPCI ES1371+ .
    Well, the sound card works just fine. BUT, Skype refuses to run giving the following error message:

    skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

    Actually, the both modules libasound.so.2 do present in the /usr/lib and /usr/lib64.

    However,
    1) "rpm -aq | grep alsa-lib" gives empty string.

    2) "ldd /usr/bin/skype | grep not" gives
    libasound.so.2 => not found


    3) "ldd /usr/bin/skype" gives

    linux-gate.so.1 => (0xffffe000)
    libasound.so.2 => not found
    libXv.so.1 => /usr/lib/libXv.so.1 (0xf7f3c000)
    libXss.so.1 => /usr/lib/libXss.so.1 (0xf7f38000)
    libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf7ecf000)
    libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf7e8c000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf7e48000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf755e000)
    etc...


    Can someone give me a clue how to repair skype ?

    Do you have the 32bit version of alsa? If not install it. skype is 32bit, not 64bit.
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •