Results 1 to 3 of 3

Thread: yast stop working after upgrading to gnome 2.28

  1. #1

    Unhappy yast stop working after upgrading to gnome 2.28

    Hi all
    my system is opensuse 11.1 with

    Code:
    Linux version 2.6.27.37-0.1-default (geeko@buildhost) (gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux) ) #1 SMP 2009-10-15 14:56:58 +0200
    and this is my zypper lr -d

    Code:
    #  | Alias                | Nome                                                  | abilitato | Attualizza | Priorit | Tipo   | URI                                                                                 | Servizio
    ---+----------------------+-------------------------------------------------------+-----------+------------+----------+--------+-------------------------------------------------------------------------------------+---------
    1  | 20091026-142900      | 20091026-142900                                       | S        | S         |   90     | rpm-md | http://download.opensuse.org/repositories/GNOME%3a/Factory/openSUSE_11.1/           |         
    2  | KDE_4.3              | KDE 4.3                                               | S        | S         |  100     | rpm-md | http://download.opensuse.org/repositories/KDE%3a/43/openSUSE_11.1                   |         
    3  | Linux-PAM            | Linux-PAM                                             | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/Linux-PAM/openSUSE_11.1/                  |         
    4  | Science              | Science                                               | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_11.1                     |         
    5  | X11:XGL              | X11:XGL                                               | S        | S         |   90     | rpm-md | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.1_GNOME_Factory/     |         
    6  | devel:tools:building | devel:tools:building                                  | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/     |         
    7  | openSUSE 11.1-0      | openSUSE 11.1-0                                       | S        | S         |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                            |         
    8  | repo                 | openSUSE BuildService - OpenOffice.org                | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/     |         
    9  | repo-debug           | openSUSE-11.1-Debug                                   | No        | S         |  120     | NONE   | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                      |         
    10 | repo-non-oss         | openSUSE-11.1-Non-Oss                                 | S        | S         |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                        |         
    11 | repo-source          | openSUSE-11.1-Source                                  | S        | S         |  120     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/                     |         
    12 | repo-update          | openSUSE-11.1-Update                                  | S        | S         |  120     | rpm-md | http://download.opensuse.org/update/11.1/                                           |         
    13 | repo_1               | openSUSE BuildService - Virtualizzazione (VirtualBox) | S        | S         |   90     | rpm-md | http://download.opensuse.org/repositories/Virtualization:/VirtualBox/openSUSE_11.1/ |         
    14 | repo_2               | openSUSE BuildService - X11:Compiz                    | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Compiz/openSUSE_11.1/                |         
    15 | repo_3               | openSUSE BuildService - Mozilla                       | S        | S         |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/                    |         
    16 | repo_4               | VideoLan Repository                                   | S        | S         |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.1/                            |         
    17 | repo_5               | Packman Repository                                    | No        | S         |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                                         |         
    18 | repo_6               | ATI Repository                                        | S        | S         |   99     | rpm-md | http://www2.ati.com/suse/11.1
    1. immediatly after upgrading to gnome 2.28 from factory I wasn't able to run yast getting the following error:

    Code:
    /usr/lib/YaST2/bin/y2controlcenter-gnome: symbol lookup error: /usr/lib/YaST2/bin/y2controlcenter-gnome: undefined symbol: apss_already_running

    yast is working from the console.

    2. compiz configuration doesn't start but compiz is working correctly

    Moreover it is impossible to delete the icon for the help center from the desktop but I can live with this
    Saluti
    R

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: yast stop working after upgrading to gnome 2.28

    Your repos are a mess. You have too many in my opinion. Try the changes shown. And run zypper up from a su terminal

    1 | 20091026-142900 | 20091026-142900 | S | S | 80 | rpm-md | Index of /repositories/GNOME:/Factory/openSUSE_11.1 |
    2 | KDE_4.3 | KDE 4.3 | S | S | 80 | rpm-md | Index of /repositories/KDE:/43/openSUSE_11.1 |
    3 | Linux-PAM | Linux-PAM | S | S | 99 | rpm-md | Index of /repositories/Linux-PAM/openSUSE_11.1 |
    4 | Science | Science | S | S | 99 | rpm-md | Index of /repositories/science/openSUSE_11.1 |
    5 | X11GL | X11GL | S | S | 90 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.1_GNOME_Factory |
    6 | devel:tools:building | devel:tools:building | S | S | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    7 | openSUSE 11.1-0 | openSUSE 11.1-0 | S | S | 120 | yast2 | Index of /distribution/11.1/repo/oss |
    8 | repo | openSUSE BuildService - OpenOffice.org | S | S | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
    9 | repo-debug | openSUSE-11.1-Debug | No | S | 120 | NONE | Index of /debug/distribution/11.1/repo/oss |
    10 | repo-non-oss | openSUSE-11.1-Non-Oss | S | S | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
    11 | repo-source | openSUSE-11.1-Source | No | S | 120 | yast2 | Index of /source/distribution/11.1/repo/oss |
    12 | repo-update | openSUSE-11.1-Update | S | S | 90 | rpm-md | Index of /update/11.1 |
    13 | repo_1 | openSUSE BuildService - Virtualizzazione (VirtualBox) | S | S | 90 | rpm-md | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1 |
    14 | repo_2 | openSUSE BuildService - X11:Compiz | S | S | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1 |
    15 | repo_3 | openSUSE BuildService - Mozilla | S | S | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    16 | repo_4 | VideoLan Repository | No | No | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    17 | repo_5 | Packman Repository | S | S | 10 | rpm-md | Index of /pub/packman/suse/11.1 |
    18 | repo_6 | ATI Repository | S | S | 99 | rpm-md | http://www2.ati.com/suse/11.1
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: yast stop working after upgrading to gnome 2.28

    Thank you.
    The problem arise probably because I choose the "one click install" for the codecs and for update the compiz-fusion that doesn't work in 11.1.

    So after the installation I had to disable the repositories inserted by the oneclickinstall.

    Anyway I'll try to wait for the 11.2
    Saluti
    R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •