I've had this error innumerable times before, and still haven't overcome it. Anyway, this morning I was trying to install a .ymp file, using Yast. When trying to install, I got this popup error:

An error occurred while initializing the software repository.
Detail:

openSUSE:11.1: [|] Valid metadata not found at specified URL(s)
History:
- File /var/tmp/TmpFile.1sTMkX doesn't contain public key data
I've had this public key error when trying to install using zypper - in fact zypper has become completely unusable on my system. I can install by
compiling (if the source code is available), but that means obtaining all the requisite libraries, which itself is hard to do without zypper/yast.

The upshot is that my system is getting extremely hard to update or extend.

Without starting from scratch (wiping my hard disk, reformatting and installing everything all over again), which seems a bit extreme, can anybody recommend some steps to fix my problem?

Thanks,
-A.