Results 1 to 9 of 9

Thread: Vuze Crashing on Start

  1. #1
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Vuze Crashing on Start

    I'm running OS 11.1x64, KDE 4.3.1.

    Vuze worked fine before updating it to version 4.2.0.8 last week. Then it started crashing on start (no screen) saying there is a missing library. The bouncing cursor would show, but the screen never came up. Now the library got fixed during an update of KDE. Now Vuze flashes the screen before it crashes (just long enough for you to see what it is.) -- something it didn't do before.

    Here's what shows when running it from a terminal:
    Code:
    bruces@linux-lsfs:~> vuze
    using MOZILLA_FIVE_HOME=/usr/lib64/xulrunner-1.9.1.4 and MOZ_PLUGIN_PATH=/usr/lib64/browser-plugins
    java virtual machine used: /usr/lib64/jvm/java/bin/java                                            
    classpath used: /usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar:/usr/share/java/Azureus/Azureus4.jar:/usr/share/java/Azureus/Azureus4.2.0.8.jar:/usr/share/java/Azureus/swt.jar                          
    main class used: org.gudy.azureus2.ui.swt.Main                                                         
    flags used:                                                                                            
    options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus -Dazureus.install.path=/var/lib/Azureus -Dazureus.script.version=2 -Dazureus.script=/usr/bin/vuze                      
    arguments used:                                                                                        
    file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/usr/share/java/Azureus/Azureus4.jar ; file:/usr/share/java/Azureus/Azureus4.2.0.8.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/home/bruces/                                                                             
    changeLocale: *Default Language* != English (United States). Searching without country..               
    changeLocale: Searching for language English in *any* country..                                        
    changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'                                                                                                   
    UIFunctions/ImageLoad took 0ms                                                                         
    new shell took 300ms                                                                                   
    new shell setup took 91ms                                                                              
    skinlisteners init took 0ms                                                                            
    skin init took 226ms                                                                                   
    MainMenu init took 225ms
    createWindow init took 0ms
    skin layout took 25ms
    pre skin widgets init took 50ms
    hooks init took 0ms
    WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@61578aab
    skin widgets (1/2) init took 276ms
    skin widgets init took 126ms
    pre SWTInstance init took 0ms
    Init Core Columns took 100ms
    SWTInstance init took 0ms
    shell.layout took 100ms
    ---------SHOWN AT 1257109164743;1764ms
    And here's what I get from "rpm -qi Vuze":

    Code:
    bruces@linux-lsfs:~> rpm -qi Vuze
    Name        : Vuze                         Relocations: (not relocatable)
    Version     : 4.2.0.8                           Vendor: http://packman.links2linux.de
    Release     : 1.1                           Build Date: Wed 21 Oct 2009 05:43:27 AM MST
    Install Date: Sun 25 Oct 2009 04:38:02 PM MST      Build Host: hauseck
    Group       : Productivity/Networking/Other   Source RPM: Vuze-4.2.0.8-1.1.src.rpm
    Size        : 14203525                         License: GPL
    Signature   : DSA/SHA1, Wed 21 Oct 2009 05:44:04 AM MST, Key ID f899f20d9a795806
    Packager    : tongra@links2linux.de
    URL         : http://azureus.sourceforge.net/
    Summary     : Java BitTorrent Client
    Description :
    Vuze (formerly) Azureus provides a bittorrent protocol implementation
    using java language.
    It offers multiple torrent downloads, queuing/priority systems (on
    torrents and files), start/stop seeding options and instant access
    to numerous pieces of information about your torrents.
    
    Azureus now features an embedded tracker easily set up and ready to
    use.
    Distribution: main / openSUSE_11.1_Update
    Thanks in advance for any help.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Vuze Crashing on Start

    Did you try renaming .azureus to .azureus_old

    Probably not this but worth a try.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Vuze Crashing on Start

    Quote Originally Posted by caf4926 View Post
    Did you try renaming .azureus to .azureus_old

    Probably not this but worth a try.
    Yes, I found that in another thread and gave it a try but no good. Vuze still flashes its screen just long enough to see what it is, then vanishes. Messages in the terminal screen were the same as before.

    Don't know if this means anything, but the torrent client Transmission works just fine and so does Ktorrent.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Vuze Crashing on Start

    Those other clients are totally different and either will do until Vuze is working again.

    I can't really see any errors in that output can you? I can offer some options. Report it to Packman.. there are email links under the Package name on the main Packman site.

    In the mean time try this. Go to this page: Browse Azureus / Vuze Files on SourceForge.net
    Expand the 4.2.0.4 and 4.2.0.8
    Download this: Download Azureus / Vuze from SourceForge.net
    And this: Download Azureus / Vuze from SourceForge.net

    The 4.2.0.8 is the version you already have but it's worth trying this file first. You now need to do this:

    According to the output you gave the file in your system is at:
    /usr/share/java/Azureus/Azureus4.2.0.8.jar
    Delete it and copy the one over you just downloaded, the same version.

    If it still does the same - delete it and put the older 4.2.04 version in there.

    FYI; you copy these .jar files as they are, don't extract them.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Vuze Crashing on Start

    Quote Originally Posted by caf4926 View Post
    Those other clients are totally different and either will do until Vuze is working again.

    I can't really see any errors in that output can you? I can offer some options. Report it to Packman.. there are email links under the Package name on the main Packman site.

    In the mean time try this. Go to this page: <snip>
    Transmission works fine for what I need to do at present. Just updating some USB stick *.iso's that have new versions.

    I tried rolling back to Vuze 4.2.0.4 as you suggested, and no joy the same symtoms occurred as with 4.2.0.8 so I suppose its time to send some email to the Packman folks. This thing is truly broken.

    For the record, I'm using the latest Java from Packman, and all my other Java stuff works with no problem. Firefox 3.5.4 works fine also. Here's the terminal output of the last try with 4.2.0.4:

    Code:
    bruces@linux-lsfs:~> vuze               
    using MOZILLA_FIVE_HOME=/usr/lib64/xulrunner-1.9.1.4 and MOZ_PLUGIN_PATH=/usr/lib64/browser-plugins
    java virtual machine used: /usr/lib64/jvm/java/bin/java
    classpath used: /usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar:/usr/share/java/Azureus/Azureus4_old.jar:/usr/share/java/Azureus/Azureus4.jar:/usr/share/java/Azureus/Azureus4.2.0.4.jar:/usr/share/java/Azureus/swt.jar
    main class used: org.gudy.azureus2.ui.swt.Main
    flags used:
    options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus -Dazureus.install.path=/var/lib/Azureus -Dazureus.script.version=2 -Dazureus.script=/usr/bin/vuze
    arguments used:
    file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/usr/share/java/Azureus/Azureus4_old.jar ; file:/usr/share/java/Azureus/Azureus4.jar ; file:/usr/share/java/Azureus/Azureus4.2.0.4.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/home/bruces/
    changeLocale: *Default Language* != English (United States). Searching without country..
    changeLocale: Searching for language English in *any* country..
    changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
    UIFunctions/ImageLoad took 25ms
    new shell took 427ms
    new shell setup took 100ms
    skinlisteners init took 0ms
    skin init took 229ms
    MainMenu init took 279ms
    createWindow init took 0ms
    skin layout took 25ms
    pre skin widgets init took 50ms
    hooks init took 0ms
    WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@60cf710e
    skin widgets (1/2) init took 329ms
    skin widgets init took 176ms
    pre SWTInstance init took 0ms
    Init Core Columns took 176ms
    SWTInstance init took 0ms
    shell.layout took 100ms
    ---------SHOWN AT 1257177489034;2360ms
    bruces@linux-lsfs:~>
    It seems to be virtually identical to the output from 4.2.0.8, save for the version change.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  6. #6
    Asem42 NNTP User

    Default Re: Vuze Crashing on Start

    I have the exactly same issue. There is a logfile "/tmp/Vuze.log" saying:

    Code:
    /usr/lib64/jvm/jre/bin/java: symbol lookup error: /usr/lib64/Azureus/libswt-xulrunner-gtk-3555.so: undefined symbol: XPCOMGlueStartup
    It looks like package Vuze-libswt3-gtk2-3.5.1-0.pm.4.1 is badly broken. I'll try to find a better one...

  7. #7
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

  8. #8
    Asem42 NNTP User

    Thumbs up Re: Vuze Crashing on Start

    It works with 11.1 too. Great!

    I'm wondering why those libs are there, if they aren't needed, except to cause probs.

  9. #9
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Vuze Crashing on Start

    Quote Originally Posted by Asem42 View Post
    It works with 11.1 too. Great!

    I'm wondering why those libs are there, if they aren't needed, except to cause probs.
    Have a look here: Fix: Vuze (Packman x86_64) broken for openSUSE 11.2. - openSUSE Forums

    The "temporary fix" seems to be following the directions on that thread. It allows Vuze to start and run, anyway.

    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •