Results 1 to 6 of 6

Thread: Suspend to RAM not working correctly in 11.2 rc2

  1. #1

    Default Suspend to RAM not working correctly in 11.2 rc2

    I was wondering if anyone else has same problem with suspend to RAM. My HP 8710p laptop falls asleep, though would not like to wake up again.

    I followed advices on NVidia, PM-Utils and S2Ram without any success. Running s2ram directly from command prompt works perfectly.

    The only thing that works I found here:
    Fix suspend to RAM on a HP8530p EliteBook on OpenSUSE 11.2 - PvdMWiki

    In short, make following changes in file: /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux

    # We only support pm-utils
    #if [ -x "/usr/sbin/pm-suspend" ]*; then
    # export NUM_SECONDS_TO_SLEEP=$seconds_to_sleep
    # /usr/sbin/pm-suspend $QUIRKS
    # RET=$?
    #else
    # # TODO: add support
    # unsupported
    #fi
    /usr/sbin/s2ram

    Anyone else having same problem?

    Kind regards,
    Arie

  2. #2

    Default Re: Suspend to RAM not working correctly in 11.2 rc2

    Could you post the output of

    cat /proc/acpi/wakeup ??
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3

    Default Re: Suspend to RAM not working correctly in 11.2 rc2

    I do have an issue with policy kit, that I reported there :
    https://bugzilla.novell.com/show_bug.cgi?id=550496

    Of course, it would work straight forward with s2ram in a terminal.

    Is it the same issue ?

  4. #4

    Default Re: Suspend to RAM not working correctly in 11.2 rc2

    The output of 'cat /proc/acpi/wakeup' is:
    Device S-state Status Sysfs node
    C0B0 S5 disabled pci:0000:00:1e.0
    C108 S3 disabled pci:0000:00:1d.0
    C10F S3 disabled pci:0000:00:1d.1
    C110 S3 disabled pci:0000:00:1d.2
    C111 S3 disabled pci:0000:00:1d.7
    C119 S3 disabled pci:0000:00:1a.0
    C11A S3 disabled pci:0000:00:1a.1
    C11B S3 disabled pci:0000:00:1a.7
    C131 S5 disabled pci:0000:00:1c.1
    C267 S5 disabled pci:0000:10:00.0
    C134 S5 disabled pci:0000:00:1c.4
    C268 S5 disabled
    C137 S5 disabled pci:0000:00:19.0
    C1FB S5 disabled

    Read about bug 550496 and I must say it looks indeed it has something to do with this problem as well, since directly s2ram from command prompt works properly. Hope they are able to fix it.

  5. #5

    Default Re: Suspend to RAM not working correctly in 11.2 rc2

    If so, you may add your case to it so that it gets more credit and probably gets solve faster.

  6. #6

    Default Re: Suspend to RAM not working correctly in 11.2 rc2

    You may fix it easily.

    Write in your /etc/init.d/boot.local

    something like

    echo USBx > /proc/acpi/wakeup

    write it for every usb you can find in /proc/acpi/wakeup (it starts with USXx.

    Problem solved
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •