Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Wine - EVE Online ties up all sounds

  1. #1

    Default Wine - EVE Online ties up all sounds

    Firstly I apologize if this question has already been asked and solved. I searched but perhaps my keywords were off.

    Problem: Running EVE Online using Wine. Runs great!

    The one issue I haven't been able to solve yet is that when I'm running the game, I'm not able to get sound out of any other application.

    I'm able to play multiple sounds at once with any other applications. I can play a video on youtube and have banshee playing at the same time, and yes, I hear the mashup of sounds, but when I have EVE going, the only thing I can hear is the game. I can launch Banshee or Totem, but they just sit there with the song progress at 0.

    Any ideas? Thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Wine - EVE Online ties up all sounds

    Quote Originally Posted by Sasquatch_Inc View Post
    Any ideas? Thanks
    Possibly you are running across a linux limitation. Here are some openSUSE sound concepts: Sound-concepts - openSUSE

    Note that most sound servers/daeons (aRts, esound ... ) do not allow sharing of audio between applications. The older version of OSS also did not allow that (there have been recent OSS updates and I do not know their status). Alsa (which is the Linux audio driver used by most Linux distributions) in addition to being a driver, also comes with an API (referred to as the alsa API). The alsa API will allow sharing of audio between applications that all use the alsa API.

    Pulse audio was intended to also provide the capability for multiple multimedia applications to share the audio device, but pulse is still buggy.

    If one can find a way to have all their multimedia applications use the alsa api (as opposed to auto, or oss, or pulse .... ) then there is a chance that one can have multiple applications playing audio at the same time.

  3. #3
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Wine - EVE Online ties up all sounds

    Run winecfg in a terminal and go to the sound tab.

    Make sure it's set to use Alsa. Although I just tried and it won't let me switch to oss!
    HP dv6645, Nvidia 8400m-gs, KDE 4.

  4. #4

    Default Re: Wine - EVE Online ties up all sounds

    Actually, I just fixed it (by looking for an answer for somebody else's problem!)

    I went into "Pulse Audio Preferences" (computer->more applications->multimedia)

    Then under the "Simultaneous Output" tab, there was only one checkbox "Add virtual output device for simultaneous output on all local cards"

    I think you have to have pulse audio turned on for your soundcard (do it via yast) for that application to show up in the menu (which is probably why I hadn't noticed it until now. I rarely go into "more applications" )

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Wine - EVE Online ties up all sounds

    Quote Originally Posted by Sasquatch_Inc View Post
    Actually, I just fixed it (by looking for an answer for somebody else's problem!)

    I went into "Pulse Audio Preferences" (computer->more applications->multimedia)

    Then under the "Simultaneous Output" tab, there was only one checkbox "Add virtual output device for simultaneous output on all local cards"

    I think you have to have pulse audio turned on for your soundcard (do it via yast) for that application to show up in the menu (which is probably why I hadn't noticed it until now. I rarely go into "more applications" )
    I am a bit suspicious that may also be a gnome specific solution, as I do not think "pulse audio preferences" is a nominal KDE selection.

  6. #6

    Default Re: Wine - EVE Online ties up all sounds

    Oh yes, thanks for the disclaimer. I am using gnome.

    I also had to restart for everything to work correctly.

  7. #7

    Default Re: Wine - EVE Online ties up all sounds

    I may have celebrated a bit too soon.

    Yes, I was able to get sounds from both Wine and my regular applications to play sound at the same time.

    Unfortunately, whenever I would open the control panel in EVE it would crash Wine.

    I experimented a bit and I found it was something with the voice setting. I tried to set things back the way they were when Wine was hogging all of the sound, but to no avail.

    Fortunately, one of the links above had a fix. I added the following to my ~/.asoundrc file, and NOW everything works!
    pulseaudio.org/wiki/PerfectSetup

    Code:
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Wine - EVE Online ties up all sounds

    Quote Originally Posted by Sasquatch_Inc View Post
    Fortunately, one of the links above had a fix. I added the following to my ~/.asoundrc file, and NOW everything works!
    pulseaudio.org/wiki/PerfectSetup

    Code:
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }
    Now THAT may be applicable to all desktops. You state you added to your ~/.asoundrc file. Typically there is no such file, although users can create one to customize their sound setup. Did you already have an exisiting ~/.asoundrc file you added to? ... or did you at this time create a new ~/.asoundrc file?

  9. #9

    Default Re: Wine - EVE Online ties up all sounds

    I created one.

    I noticed the following when I re-traced my steps.

    I originally used this configuration
    Sharing ALSA audio from Wine Me and U(buntu)

    This sets DMIX and DSNOOP as the default mixers. With this I could get simultaneous sound with Wine and Mplayer only.

    Deleteing the .asoundrc and checking the "simultaneous output" setting in Pulse Audio would allow simultaneous sound from Wine and all applications - The catch: when I would try to open the control panel in Eve, Wine would crash.

    I put in the configuration from my last reply into the .asoundrc, and everything is seemingly great.

    I have no idea why I have to have a .asoundrc file now (Did Alsa get addicted to it? ) but everything seemingly works

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Wine - EVE Online ties up all sounds

    Quote Originally Posted by Sasquatch_Inc View Post
    I put in the configuration from my last reply into the .asoundrc, and everything is seemingly great.

    I have no idea why I have to have a .asoundrc file now (Did Alsa get addicted to it? ) but everything seemingly works
    I assme you need it to stop the wine crash you refered to. I don't think you mean "addicted" but rather mean some other word?

    There was a time (mostly before I know anything about sound) when .asoundrc was mostly needed, but now thats not the case. It is mostly NOT needed. Now adays, typically only when a user has a configuration slightly outside of the nominal might a .asoundrc file offer capabilities that are not present.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •