Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: openSUSE 11.1 server will not access the internet

  1. #1

    Default openSUSE 11.1 server will not access the internet

    Please help? I have a fresh install of openSUSE 11.1 with all the servers installed. It will not access the internet. I wanted to test accessing the internet before i setup with samba, apache, ftp. The internet worked during install because i downloaded and installed mono for apache2. the server gets an ip address.
    here are the specs if it helps:
    ASUS P4c800-e Deluxe Motherboard

    • Intel 875PChipset
    • South Bridge Chip Intel ICH5R
    • Intel CSA 82547EI Gigabit Ethernet

    P4 3.0GHz Hyper threaded CPU Socket 478
    2GB Ram
    ASUS 52x CD-rom
    Sony CD-RW/DVD-ROM
    PNY nVIDIA FX5200 GPU
    2 40GB HDD on raid0 = 80GB
    One 120GB HDD
    one 160GB HDD
    Please help i have 4 days to complete before the boss says i am not head of the it dept.
    Last edited by rvanness; 31-Oct-2009 at 08:04. Reason: fogot something
    Thanks CPU-IT-Worstnightmare
    ____________________________________________________________________________________________________________________________

    If you aint running Linux than you are just feed the CEO's of M$ and APPLE.

  2. #2
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: openSUSE 11.1 server will not access the internet

    Log in as root, then try to copy and paste the results of these commands here -

    ifconfig
    route

    That is a good start.

    A few more things to check .

    Are you getting a proper IP address?
    The route should show an entry like -
    Code:
    default         router          0.0.0.0         UG    0      0        0 eth0
    ....where eth0 is your network card.

    Do you have more than 1 network card in the computer?
    Have you tried turning the firewall off?
    Can you ping the router/modem?
    HP dv6645, Nvidia 8400m-gs, KDE 4.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,777

    Default Re: openSUSE 11.1 server will not access the internet

    You say it will not access the internet. That would mean you can e.g. not use a webbrowser (FF, Konqueror) to an internet address like forums.opensuse.org.

    But then you say you will use server software like apache. This type of software will not connect to the Internet, by you may want connection from the Internet to your server software.

    Big difference when e.g. the configuration of your firewall or of the firewall in your router are to be done correct.

    Questions:
    1) do you have network connection at all (to other systems in the LAN, at least to your router)?
    2) when yes, can you access Internet servers (using FF, etc.)?
    3) now you can contemplate on incomming traffic and look to the config of your router, etc.
    Henk van Velden

  4. #4

    Default Re: openSUSE 11.1 server will not access the internet

    I can not see other computers/routers/switches etc. I have an ip address of 192.168.1.76 from the router. This server is going to be a workstation/server so i installed KDE 4.1. So that means i need to be able to come in and go out. yes i disabled the firewall.
    ifconfig

    br0 Link encap:Ethernet HWaddr 00:0E:A6:5A:AC:94
    inet addr:192.168.1.76 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:671 errors:0 dropped:0 overruns:0 frame:0
    TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:107696 (105.1 Kb) TX bytes:4098 (4.0 Kb)

    eth0 Link encap:Ethernet HWaddr 00:0E:A6:5A:AC:94
    inet addr:192.168.1.76 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:688 errors:0 dropped:0 overruns:0 frame:0
    TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:121431 (118.5 Kb) TX bytes:10640 (10.3 Kb)
    Interrupt:22

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:58 errors:0 dropped:0 overruns:0 frame:0
    TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4366 (4.2 Kb) TX bytes:4366 (4.2 Kb)

    route

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.1.0 * 255.255.255.0 U 0 0 0 br0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.1.254 0.0.0.0 UG 0 0 0 eth0
    Thanks CPU-IT-Worstnightmare
    ____________________________________________________________________________________________________________________________

    If you aint running Linux than you are just feed the CEO's of M$ and APPLE.

  5. #5

    Default Re: openSUSE 11.1 server will not access the internet

    I cannot ping anything except 127.0.0.1 the loopback. If i try to access it from another machine. i get an error. when i go into the router from another machine the router sees it and listed the dhcp ip address. the last server i built for myself i had to disable dhcp6 inorder to get out to the internet. so i tried that with this one installed same as mine no internet so i disabled dhcp6 with no luck. the internet quit working at the configuration part of the install when it gets to the step check for updates and check internet. it would not work then.
    Thanks CPU-IT-Worstnightmare
    ____________________________________________________________________________________________________________________________

    If you aint running Linux than you are just feed the CEO's of M$ and APPLE.

  6. #6
    Join Date
    Oct 2008
    Location
    Stuttgart - Germany
    Posts
    163

    Default Re: openSUSE 11.1 server will not access the internet

    Download this script and execute it. This will analyze your network config and create warning or error messages which help to solve the problem on your own. Otherwise post the summary file created which has a lot of details about your network and will help us to help you

  7. #7

    Default Re: openSUSE 11.1 server will not access the internet

    With that setup, this is not really a surprise.

    A) What do you need that bridge for?

    B) Why are there two interafces (br0 and eth0) not only in the same subnet but also with the same IP?

    C) If that bridge is really needed (I doubt it), then there is only one physical interface it could be "bridged to". You do know, that this interface will _not_ be available as a "normal" interface any longer?

    In any case, execute the script mentioned above, maybe then one can see how to clean up this mess.

  8. #8

    Default Re: openSUSE 11.1 server will not access the internet

    Would it be easier to just to reinstall suse without the install Xen virt machine manager
    Thanks CPU-IT-Worstnightmare
    ____________________________________________________________________________________________________________________________

    If you aint running Linux than you are just feed the CEO's of M$ and APPLE.

  9. #9

    Default Re: openSUSE 11.1 server will not access the internet

    the br0 is for xen virt machine. we have sun xvm virtual box on a cd for a virtual machine tool.
    Thanks CPU-IT-Worstnightmare
    ____________________________________________________________________________________________________________________________

    If you aint running Linux than you are just feed the CEO's of M$ and APPLE.

  10. #10
    Join Date
    Oct 2008
    Location
    Stuttgart - Germany
    Posts
    163

    Default Re: openSUSE 11.1 server will not access the internet

    Quote Originally Posted by Akoellh View Post
    B) Why are there two interafces (br0 and eth0) not only in the same subnet but also with the same IP?
    Good catch!
    @rvanness: Just delete the bridge and you should be fine.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •