Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Session is always locked in kde 4

  1. #1
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Unhappy Session is always locked in kde 4

    Hi

    in opensuse 11.1 : how come my session is always locked in KDE 4.3.1 "release 179" ?

    I did not choose this on purpose and don't see where to change this.

    thanks for ideas to improve this
    openSUSE Leap 42.2 , KDE Plasma 5

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,730
    Blog Entries
    20

    Default Re: Session is always locked in kde 4

    When is it locked? When you login? When you leave it a while not doing anything?
    You probably need to switch off powersaving and screen locking
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Question Re: Session is always locked in kde 4

    When i leave it a while , but the fact is i did not switch on any powersaving, nor screen lock.

    in syst config/desktop , the mandatory password box is not ticked


    in in syst config/advanced thumb : powersaving general config allows to lock screen, this is off too.

    Is there somehting else ?

    What's wrong then ?
    openSUSE Leap 42.2 , KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,730
    Blog Entries
    20

    Default Re: Session is always locked in kde 4

    Check in Power Management - General Settings
    Look for Lock Screen on resume

    Check thru all the settings, they are kind of all over the place.

    Also check in desktop - screensaver
    un-check everything
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Session is always locked in kde 4

    well , as i said above lock on resume is not used,
    features all other the place as you said but not linked with locking the screen.

    and in desktop screensaver : i'm just using the screensaver, do you mean using it locks (?)

    is this thing just not working ? have you heard of such problems before ? (this used to be ok)
    openSUSE Leap 42.2 , KDE Plasma 5

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,730
    Blog Entries
    20

    Default Re: Session is always locked in kde 4

    i'm just using the screensaver, do you mean using it locks (?)
    I think it tends to, I would just try NOT using it at all and see what happens rather than me trolling thru all the settings to see where you might be going wrong.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,730
    Blog Entries
    20

    Default Re: Session is always locked in kde 4

    Also see here that it's not checked
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Session is always locked in kde 4

    Well , you or someone else could have known the source of the problem

    i can uncheck screen savers and maybe it's gonna solve this lock problem , but isn't a screen saver mandatory to protect the screen's life ?
    Does it need a bug report ?

    On the picture you gave i had ticked the box, i unbchecked it to see if it does the trick, but if so it's still strange for i can't see any visible link with this and locking the screen.
    openSUSE Leap 42.2 , KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,730
    Blog Entries
    20

    Default Re: Session is always locked in kde 4

    You are correct. I personally think the settings in this area are a mess. As for screen savers. I just turn my screen off, which means I just have to press a button. All my screens outlive my use of them. In other words, I'll want a bigger or better one long before it goes BANG!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    palladium NNTP User

    Default Re: Session is always locked in kde 4

    manchette fr wrote:
    > isn't a screen saver mandatory to protect the screen's life ?


    no....back at the dawn of internet time (circa 1970s/80s) screens were
    made with phosphorus bits which illuminated when hit by the cathode
    ray tube's stream of emitted electrons..

    eventually, each tiny phosphorus bit would 'wear out' and no longer
    glow with expected level of luminance and if you left the same (say)
    line of text on the screen long enough it would 'burn in' and its
    'ghost' could be visible even when the text was removed..

    today, they are pretty much unnecessary eye candy adding needless
    pollutants to the atmosphere by using CPU cycles drawing artistically
    interesting shapes, colors, etc..

    imo, it is much better to save those cycles (and the electricity
    required to calculate and display them) by by selecting "Blank Screen"
    and then, when you walk away from the machine, turn off the screen
    itself (as do caf and i), for double savings..

    more at: http://en.wikipedia.org/wiki/Screensaver

    --
    palladium
    Have a lot of fun..

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •