Results 1 to 5 of 5

Thread: 'x11failsafe' parameter. Xperts, some help!

  1. #1

    Default 'x11failsafe' parameter. Xperts, some help!

    Just discovering Linux.
    I ran into a problem the moment i installed 11.1. The GUI wouldn't show up (ctrl+alt+f2 yeilded a black screen with a blinking underscore).

    Failsafe worked fine, though.

    So, i tried entering, one by one, every parameter that was entered in the failsafe boot options. Entering 'x11failsafe' gave me a flawless GUI. So, i opened the '/boot/grub/menu.lst' file and added this parameter in the 'showopts' of the normal mode, to make it permanent.

    Fine. Now, what exactly have i done?

    Note- I use an NVidia 8000 series Graphic card. I'll post more details if you need them.

    PS- These threads talk about the same issue, but i can't see a solution (if, indeed, there is a problem):
    Blank Unless x11failsafe
    Can only Boot x11failsafe

  2. #2

    Default Re: 'x11failsafe' parameter. Xperts, some help!

    Installed Graphic Card drivers. Parameter no longer needed.
    Nevertheless, what does "x11failsafe" mean? A special (low-end) X server configuration for Failsafe, is it...

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 'x11failsafe' parameter. Xperts, some help!

    It uses the VESA driver instead of nv for nVidia or ati/radeon/radeonhd for ATI.

  4. #4

    Default Re: 'x11failsafe' parameter. Xperts, some help!

    Hmm...
    I downloaded the KDE Partition Manager Live CD recently. It's GUI refused to show too. I tried the "x11failsfe"parameter, but i don't think it was recognized.

    Is there another general boot argument, used more or less universally, that launches the X server with the basic VESA driver?

  5. #5

    Default "xmodule=vesa"?

    Is "xmodule=vesa" the parameter i'm looking for?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •