Results 1 to 2 of 2

Thread: Yet another booting from usb drive question.

  1. #1

    Default Yet another booting from usb drive question.

    Hello. I have Vista on my system, and I want to install suse on my usb harddrive, leaving my internal hard drive untouched. I made an install dvd and have gone through the install steps, except for the part which says to start writing.

    In the the portable suse article,

    It states the following:

    =====
    Follow the setup wizard to the configuration of GRUB

    Proceed to Installation Settings

    Select Expert mode in the Boot Loader Installation tab of Boot Loader Settings dialog

    Select Boot from Root Partition for the Boot Loader Location option.

    After the installation, SuSE will reboot automatically. Directly booting, even from the BIOS "USB Boot" will probably fail, so boot from the installation DVD again.

    Proceed to Installation Mode and select Boot Installed System from Other Options, to complete the installation.
    ======

    Okay, when I go through the installer on the dvd, I go to the "boot loder installation" tab, and I see the following selected:

    Boot loader: Grub
    Boot loader locations:
    [] Boot from boot partition
    [] Boot from extended partition
    [] boot from master boot record
    [] boot from root partition
    [] custom boot partition

    Do I just check "boot from root partition" and keep all others unchecked? Do I need to mess around with custom boot partition? I root partition and custom boot partition are both checked.

    In a previous step I believe I have selected default settings for my partitions.


    thanks.

  2. #2

    Default Re: Yet another booting from usb drive question.

    It should run fine with the bootloader just on the root partition I think. If it doesn't, manually installing grub the MBR of that disk isn't hard, so don't worry about just going for it.

    If you're selecting the USB drive in a BIOS boot list, it's possible that the reordering of drives will confuse it.

    You might want to either try reinstalling and changing grub's list of drives to that the USB drive appears first

    Code:
    (hd0)  /dev/sdc
    (hd1)  /dev/sda
    (hd2)  /dev/sdb
    something like that, if the drive you're installing to is designated sdc, or just manually altering /boot/grub/device.map accordingly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •