Results 1 to 3 of 3

Thread: Need some package updates in http://download.opensuse.org/re

  1. #1

    Default Need some package updates in http://download.opensuse.org/re

    I'm building some Twitter apps in openSUSE 11.2 using the Perl Twitter API library. Unfortunately, what's in Index of /repositories/devel:/languages:/perl/openSUSE_11.2 is release 2.12 of "perl-net-Twitter". Upstream (CPAN) has 3.x already, and there's also a "Net::Twitter::Lite" in CPAN that's not even in the OBS repository. How do I go about requesting / helping get these packages updated?

    For now, I'm loading the packages directly from CPAN, which mostly works, as far as I can tell, but there could be hidden gotchas with a mixed CPAN / openSUSE system.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,172
    Blog Entries
    15

    Default Re: Need some package updates in http://download.opensuse.org/re

    Quote Originally Posted by znmeb
    I'm building some Twitter apps in openSUSE 11.2 using the Perl Twitter
    API library. Unfortunately, what's in 'Index of
    /repositories/devel:/languages:/perl/openSUSE_11.2'
    (http://tinyurl.com/yz5hj26) is release 2.12 of "perl-net-Twitter".
    Upstream (CPAN) has 3.x already, and there's also a "Net::Twitter::Lite"
    in CPAN that's not even in the OBS repository. How do I go about
    requesting / helping get these packages updated?

    For now, I'm loading the packages directly from CPAN, which mostly
    works, as far as I can tell, but there could be hidden gotchas with a
    mixed CPAN / openSUSE system.
    Hi
    Look here and there is a Perl template you can use for the rpm spec
    file;
    http://en.opensuse.org/SUSE_Build_Tutorial#Specfiles

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 20 days 5:00, 3 users, load average: 0.81, 0.38, 0.15
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  3. #3

    Default Re: Need some package updates in http://download.opensuse.or

    Thanks!! That should be all I need!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •