Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Nvidia Drivers Won't Load

  1. #1

    Default Nvidia Drivers Won't Load

    I'm working on my dad's computer with a new 11.1 installation and an AGP Nvidia GeForce 6800 XT, and I've never run into such difficulty enabling 3D support.

    I've run the one-click installer for the drivers, and it changes the xorg "driver" line to "nvidia," which crashes X upon restarting the server.

    I've tried running "sax2 -r -m 0=nvidia" as root from runlevel 3, and the same thing happens.

    I can get back into GNOME by manually changing the "driver" line to either "nv" or "vesa," but I have no acceleration.

    I've also looked through some troubleshooting posts regarding a kernel mismatch and having PAE installed, but everything seems to match correctly.

    Can anyone help me out? I'd like for my dad to be able to use Google Earth, as he's a real enthusiast for it.

    Here's my xorg.conf:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Fri Aug 14 17:54:58 PDT 2009
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-10-27T22:33:52-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Logitech USB Optical Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "GATEWAY"
        ModelName      "VX900T"
        UseModes       "Modes[0]"
        DisplaySize     352    264
        HorizSync       30.0 - 96.0
        VertRefresh     48.0 - 120.0
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"
        Option         "PreferredMode" "1280x1024"
    EndSection
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nv"
        VendorName     "NVIDIA"
        BoardName      "GeForce 6800 XT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24
        SubSection     "Display"
            Depth       15
            Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "on"
    EndSection

  2. #2

    Default Re: Nvidia Drivers Won't Load

    Hi palsyboy,
    I've the same NVidia Card and the same problem here.
    So far (almost 1 + 1/2 years) I could not manage my nvidia card to work.

    Seems "Nvidia 6800" is not supported by the driver.

  3. #3
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    731

    Default Re: Nvidia Drivers Won't Load

    I've never had any luck using "one click" to install drivers for an NVIDIA gpu, and I get the impression from reading these forums that nobody else has either.

    The more successful method is really easy. I never use any method other than " "the hard way" to install NVIDIA drivers. It's really not hard at all. It only takes about two minutes, and I think it's easier than any alternative.

    here's how I do it:

    1. go to NVIDIA Driver Downloads - Advanced Search and find and download the driver for your card. Make sure to remember where you stored the file.

    2. ctrl-alt-f1

    3. login as su

    4. # init 3

    5. # cd (the path to the downloaded file)
    (I do it this way so I can now run # ls if needed to verify the name of the file for the next step)

    6. # sh (the driver file) -q

    7. sax2 -r -m 0=nvidia

    8. then I reboot just to be conservative

    Good luck
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

  4. #4
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    731

    Default Re: Nvidia Drivers Won't Load

    Quote Originally Posted by alibab View Post
    Seems "Nvidia 6800" is not supported by the driver.
    According to NVIDIA, no problem, it's supported.
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Nvidia Drivers Won't Load

    Further to caprus post, ... I also use the "hardway", ... but if one is going to go that route, first ensure you:
    • under yast > software > software management select the pattern "base development" and install those associated packages, and
    • install kernel-source, kernel-syms and linux-kernel-headers (note kernel-source and kernel-syms MUST be of same version as your kernel).
    Those are needed to build your driver when one does it the "hardway" (which is not hard).

  6. #6

    Default Re: Nvidia Drivers Won't Load

    thx all for the kind reply,
    @caprus: I already use this way of installing nvidia drivers.
    It just doesn't work with this card.
    On my laptop with "nvidia 7800 GO" your solution worked immediately. But on my desktop PC with "nvidia 6800" I just can not get this card working. It seems I'm not the only one ...

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Nvidia Drivers Won't Load

    Quote Originally Posted by alibab View Post
    On my laptop with "nvidia 7800 GO" your solution worked immediately. But on my desktop PC with "nvidia 6800" I just can not get this card working. It seems I'm not the only one ...
    Hmmm ... which openSUSE versions did you try? Which nVidia graphic card versions/files did you try?

    Have you tried to get help on the nVidia Linux forum? I find it very good:
    NVIDIA Linux - nV News Forums

    Have you raised a bug on the driver on the Nvidia web site?

  8. #8
    Lachrymose NNTP User

    Default Re: Nvidia Drivers Won't Load

    I have this problem too. I'm not sure how to get into gnome to change this. I'm new to openSuse and not much Linux experience in general.

    All I get is a terminal prompt while booting with some display errors. This all happened after the "one click install" for nvidia, lol.

    I appreciate any help and am grateful that this thread is active when I need it!

    EDIT: I want to do this: get back into GNOME by manually changing the "driver" line to either "nv" or "vesa,"

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Nvidia Drivers Won't Load

    Quote Originally Posted by Lachrymose View Post
    I have this problem too. I'm not sure how to get into gnome to change this. I'm new to openSuse and not much Linux experience in general.

    All I get is a terminal prompt while booting with some display errors. This all happened after the "one click install" for nvidia, lol.

    I appreciate any help and am grateful that this thread is active when I need it!

    EDIT: I want to do this: get back into GNOME by manually changing the "driver" line to either "nv" or "vesa,"
    If you can boot to a text mode, and if you have a nvidia card, then switch to root permissions (you can do that by typing "su" without specifying a user and enter root password) and then type:
    sax2 -r -m 0=vesa
    or
    sax2 -r -m 0=nv
    then restart with
    shutdown -r now
    Thats assuming only one graphic device.

    If more than one you may need to change the "0" to "1".

  10. #10
    Lachrymose NNTP User

    Default Re: Nvidia Drivers Won't Load

    Thanks for the reply! I was able to boot into gnome. But now when I try to download the driver, there are no results on the nvidia sit for my drivers (Geforce 7000M). I'm not really sure what to do now.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •