Results 1 to 4 of 4

Thread: Slow/Laggy windows & apps response

  1. #1

    Default Slow/Laggy windows & apps response

    I am still learning my way around Suse 11.0. I have an onboard graphics card that claims to be using an ATI Mach64 GR driver with no 3D support. I don't actually know what the size of the video card is, nor do I know what driver I should be using. I am just going with what Suse defaulted to.

    I installed Suse a few weeks ago and have not been able to solve the slow/laggy response of my windows and apps. Typing is moderately slow, and I get ghost images when I drag windows (firefox, konqueror, etc.) around the screen which sometimes causes other programs to freeze.

    The computer is a 4 core Intel(R) Xeon(TM) CPU 2.80 GHz, 1 GB RAM, 2 TB HDs, Linux 2.6.25.20-0.5-pae i686. Something I just noticed, and don't know how it happened, is the System is openSUSE 11.0 i586. Will this cause a problem with the installed kernel because it is i686?

    Thanks for your help

  2. #2

    Default Re: Slow/Laggy windows & apps response

    You have a tremendous amount of compute capacity in your machine. No reason in the world to tolerate sluggish performance.

    First, verify your installed kernel:
    Code:
    uname -a
    Then, take at look at your hardware. Yast has a nice Hardware Information icon for this task. Verify the instruction width of your CPU. If it's 64bit, then your kernel should be x86_64.

    If you have the wrong-sized kernel it is not a disaster, but it's something to correct. These days, the 64bit kernels are fine.

    If the kernel is OK, find out which process is hogging the machine's resources:
    Code:
    top
    In the header, you should see CPU usage as mostly "id" (idle). In the list of processes, see how much memory the first few are consuming (the RES column). If the sum of RESs exceeds your installed memory capacity, you will notice a nonzero amount used in the Swap line in the header--you are swapping memory to disk, and running a few thousand times slower than you would if you had everything in RAM.

    If you are not swapping to disk, you could just have a defective video driver. It's hard to say. Try logging in without X (i.e. command line only), see if the system is still sluggish. It can be very frustrating to pin down a performance bottleneck, but it is rewarding when you succeed. Good luck.

    Hope this helps.

  3. #3

    Default Re: Slow/Laggy windows & apps response

    I did as you suggested. I do not have a 64-bit system, so my kernel is good.

    I ran "top" and noticed that Xorg is right at the top. As I'm typing this, it's using 2% CPU and 2.0% MEM. However, if I start dragging windows around the screen (to produce the ghosting) the Xorg shoots up to as much as 90% CPU and MEM is unchanged. I want to say this is consistent with a fully working XP system (it's what I know best).

    Here's the summary output:

    top - 10:24:57 up 1 day, 26 min, 4 users, load average: 0.25, 0.29, 0.21
    Tasks: 140 total, 1 running, 139 sleeping, 0 stopped, 0 zombie
    Cpu(s): 2.1%us, 0.3%sy, 0.0%ni, 97.5%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 1034672k total, 1017388k used, 17284k free, 218124k buffers
    Swap: 8193100k total, 444k used, 8192656k free, 399684k cached


    I spoke to a colleague of mine and he seems to think that I'm having problems because I don't have enough memory and am using an on-board video card. Can anyone comment on this? This system was running flawlessly on a much older version of CentOS.

  4. #4

    Default Re: Slow/Laggy windows & apps response

    Adding 1G of RAM would solve your immediate problem, and is probably wise in any event.

    You have a relatively high amount of swap space declared. I would reduce this to 1G. Reasoning: even a slight use of swap slows the system down unacceptably, why set aside any more than you have to? (Some folks run with zero swap with no problems).

    HTH

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •