Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Need some help with remote desktop connections

  1. #1
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Need some help with remote desktop connections

    I'm competely lost when it comes to doing this. I copied these commands from another thread:

    ssh -t -L 5900:localhost:5900 oldcpu@ip-address-of-pc-2 'x11vnc -localhost -nolookup -nopw -display :0'

    What do I put for "oldcpu@ip-address-of-pc-2"? Right now I'm in the same room with the pc I want to connect to, but I plan on doing it from 600 miles away. The pc I'm trying to connect to is behind a router and the ip address is 192.168.1.2.

    I tried using Krfb and Krdc and sending myself an invite but I had no luck. I set port 5900 to port forwarding on the router but I don't know if that's right.

    Can anyone help?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Need some help with remote desktop connections

    On Wed, 28 Oct 2009 23:06:02 +0000, pilotgi wrote:

    > What do I put for "oldcpu@ip-address-of-pc-2"?


    Replace "oldcpu" with your username on the remote system and 192.168.1.2
    for "ip-address-of-pc-2".

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  3. #3
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: Need some help with remote desktop connections

    Thanks for the quick answer. The result of the command was "port 22: Connection refused." I configured port forwarding on port 22 in the router, but I got the same result on the second try.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Need some help with remote desktop connections

    On Wed, 28 Oct 2009 23:56:02 +0000, pilotgi wrote:

    > Thanks for the quick answer. The result of the command was "port 22:
    > Connection refused." I configured port forwarding on port 22 in the
    > router, but I got the same result on the second try.


    I'd probably start by just trying to ssh to the box without the extra
    commands - just "ssh user@192.168.1.2" (substitute the user name for
    "user") and see if you can get a connection.

    You might also need to open port 22 in the target system's firewall.

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  5. #5
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: Need some help with remote desktop connections

    I wasn't sure if I was configuring the firewall right so I just turned it off and I still got the connection refused to port 22 message, with the shortened command as you suggested.

    As far as configuring the firewall goes is it YaST2 > Firewall Configuration > Allowed services > Advanced?

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Need some help with remote desktop connections

    On Thu, 29 Oct 2009 00:56:01 +0000, pilotgi wrote:

    > I wasn't sure if I was configuring the firewall right so I just turned
    > it off and I still got the connection refused to port 22 message, with
    > the shortened command as you suggested.
    >
    > As far as configuring the firewall goes is it YaST2 > Firewall
    > Configuration > Allowed services > Advanced?


    That would be the place to make the change, but disabling the firewall
    also would have the same effect.

    Let's try a couple commands from the system you're connecting from:

    1. ping 192.168.1.2

    That will check basic connectivity.

    2. telnet 192.168.1.2 22

    That will check to see if we can get a response on the default ssh port
    (assuming here that you haven't changed it).

    What responses do you get to those two commands?

    Jim
    --
    Jim Henderson
    openSUSE Forums Moderator

  7. #7
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: Need some help with remote desktop connections

    Ping to 192.168.1.2 was successful. Result of telnet 192.168.1.2 22:

    Trying 192.168.1.2...
    telnet: connect to address 192.168.1.2: Connection refused

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Need some help with remote desktop connections

    On Thu, 29 Oct 2009 01:16:03 +0000, pilotgi wrote:

    > Ping to 192.168.1.2 was successful. Result of telnet 192.168.1.2 22:
    >
    > Trying 192.168.1.2...
    > telnet: connect to address 192.168.1.2: Connection refused


    Next step would be to check and see if sshd is running on the target
    server - sounds like it probably isn't.

    In YaST on the target machine, select "System Services" and make sure
    sshd is set to "enabled" (in simple mode; in expert mode, you'll probably
    want to enable runlevels 3 and 5).

    Jim
    --
    Jim Henderson
    openSUSE Forums Moderator

  9. #9
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: Need some help with remote desktop connections

    I enabled remote access through YaST > Network services and sshd in System Services, runlevel 3 and 5. Now I get this when I do ssh user@192.168.1.2:

    The authenticity of host '192.168.1.2 (192.168.1.2)' can't be established.
    RSA key fingerprint is 66:23:61:a9:b8:1d:7b:48:96:ff:e2:18:79:d5:31:ff.
    Are you sure you want to continue connecting (yes/no)? Yes.
    Host key verification failed.

  10. #10
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Need some help with remote desktop connections

    On Thu, 29 Oct 2009 17:26:01 +0000, pilotgi wrote:

    > I enabled remote access through YaST > Network services and sshd in
    > System Services, runlevel 3 and 5. Now I get this when I do ssh
    > user@192.168.1.2:
    >
    > The authenticity of host '192.168.1.2 (192.168.1.2)' can't be
    > established.
    > RSA key fingerprint is
    > 66:23:61:a9:b8:1d:7b:48:96:ff:e2:18:79:d5:31:ff. Are you sure you want
    > to continue connecting (yes/no)? Yes. Host key verification failed.


    That's a step in the right direction - the sshd daemon is now running and
    is allowing an initial connection to be made.

    But it's odd that it's failing the host key verification after you answer
    "yes". What version of the OS (and sshd) is on the target system?

    I'm not able to duplicate the failure on my systems - I'm guessing that
    on your target system, "Yes." is not "yes" and that may be why it's
    failing. It's a long shot, though.

    Is there anything in the target system's /var/log/messages file relating
    to the connection attempt?

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •