Results 1 to 3 of 3

Thread: OpenSuse 11.1 updated to Gnome 2.26 - now having problems with Gtk+

  1. #1
    David Gersic NNTP User

    Default OpenSuse 11.1 updated to Gnome 2.26 - now having problems with Gtk+

    Monday night, I used Yast to apply all available updates to my
    workstation. Prior to this, everything was working fine, but I hadn't
    applied any updates for about six months.

    After updating, Gnome is not happy.


    Symptom #1: Trying to use Gnome Terminal, I get these messages:

    (gnome-terminal:11102): Gtk-WARNING **: GModule
    (/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization check
    failed: Gtk+ version too old (micro mismatch)

    (gnome-terminal:11102): Gtk-WARNING **: GModule
    (/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization check
    failed: Gtk+ version too old (micro mismatch)

    (gnome-terminal:11102): Gtk-WARNING **: GModule
    (/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization check
    failed: Gtk+ version too old (micro mismatch)

    (gnome-terminal:11102): Gtk-WARNING **: GModule
    (/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization check
    failed: Gtk+ version too old (micro mismatch)
    The program 'gnome-terminal' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadValue (integer parameter out of range for operation)'.
    (Details: serial 316 error_code 2 request_code 94 minor_code 0)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error()
    function.)


    Symptom #2: Entering Yast/Software Management goes ok. When I exit
    Software Management, though, I get a pop-up windows with several of these
    same errors in it:

    Gtk-WARNING **: GModule (/usr/lib/gtk-2.0/2.10.0/engines/
    libclearlooks.so) initiaization check failed: Gtk+ version too old (micro
    mismatch)

    Similarly, Yast/Software Repositories opens ok, but on closing it, I get
    the same pop-up window of error messages.



    Google turned up what looks like the same symptoms here:
    http://lists.opensuse.org/opensuse-f.../msg00153.html

    I tried changing the openSUSE-11.1-update repo priority from 20 to 99 as
    suggested, updated again, and afterward still have the same problem.

    I can use the Konsole terminal from Kde, though I'm using Gnome as the
    desktop environment. Enable or "disable desktop" effects has no affect on
    the problem.

    Both the Gnome-Terminal package and the Gtk2-engines package claim to be
    from Gnome 2.26.

    Before I start trying to back this mess out to Gnome 2.24, anybody got
    any ideas on getting Gnome 2.26 to work correctly?



    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  2. #2

    Default Re: OpenSuse 11.1 updated to Gnome 2.26 - now having problem

    Check your version of gtk2. I am running 2.26 and my current version is 2.16.5-1.4. Works fine.

  3. #3
    David Gersic NNTP User

    Default Re: OpenSuse 11.1 updated to Gnome 2.26 - now having problems withGtk+

    On Wed, 28 Oct 2009 19:06:01 +0000, JJMT wrote:

    > Check your version of gtk2. I am running 2.26 and my current version is
    > 2.16.5-1.4. Works fine.


    dgersic@linux:~> rpm -qa | grep -i gtk2 pinentry-gtk2-0.7.5-61.18.1
    gtk2-engines-2.18.2-1.4
    gtk2-theme-openSUSE-11.1-2.1
    gtk2-devel-2.14.4-8.7.1
    gtk2-themes-0.1-737.56
    gtk2-2.14.4-8.7.1
    gtk2-branding-openSUSE-11.1-2.1


    Upgraded gtk2 to 2.16.5-1.6, changed source to Gnome:Stable 2.26 Upgraded
    gtk2-devel to 2.16.5-1.6, changed source to Gnome:Stable 2.26


    And that seems to have done the trick. I've got Gnome-Terminal working
    again, and the pop-up errors exiting Yast have stopped.

    Thanks.


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •