Results 1 to 4 of 4

Thread: NVIDIA Problem

  1. #1
    Ammanas NNTP User

    Default NVIDIA Problem

    I'm using an NVIDIA GeForce 9500m GS on an ASUS laptop.

    Ok, I installed openSuse early last week and everything worked perfectly. However, I was unable to enable desktop effects even though my laptop is pretty new and the graphics card is supposed to be excellent. I did what I think now was a kinda dumb thing to do which was try to alter the settings in order for desktop effects to work.

    I performed the NVIDIA driver installation from the opensuse web site and ran the command

    Code:
    #sudo nvidia-xconfig
    Upon doing so, I restarted X and lo and behold, X fails to start. I apparently couldn't load the NVIDIA kernal module. I booted the failsafe and it worked just fine and I followed some various topics on the subject but to no avail.

    All I would like to do at this point is set my Xserver configuration back to its default.

  2. #2
    Ammanas NNTP User

    Default Re: NVIDIA Problem

    Sorry 'bout bugging you guys about that, I just fixed it by adding
    Code:
    acpi=off noapic
    to the boot options.

  3. #3

    Default Re: NVIDIA Problem

    If memory servesme right then you should run sax2 -r -m 0=nvidia (as root and init 3) and not nvidia-xconfig. Though you can always combine some stuff from nvidia-xconfig and apply it to your settings. nvidia-xconfig is only there for distros that have no tool designed to configure the graphic card, suse got that so there is no need for nvidia-xconfg.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  4. #4
    Join Date
    Jun 2009
    Location
    Dallas, TX
    Posts
    16

    Default Re: NVIDIA Problem

    the way I install my GeForce7000m is just by going to nvidias website and downloading the bin file. I never use the ones provided by suse because most of the time its for another kernel version.

    Its easy, just exit X and login into the console as root and run the bin file, it compiles a driver for your kernel version and writes to the appropriate config files. Its all automated, and it never fails. You just gotta have the kernel sources installed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •