Results 1 to 7 of 7

Thread: no working group: howto share files? (smb.conf included)

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default no working group: howto share files? (smb.conf included)

    After some problems i got my notebook wlan device working and connected with my router (have internet access know).
    But now i even want to share files between my desktop pc and laptop.
    Both are connected with the router:
    - the notebook with wlan (opsensuse and kde)
    - the desktop pc with normal lan (windows vista)
    i had some problems setting kde up to share files but i got it, but when going to: smb:/
    i got the message (i try to translate it from german to english): "No working group found. Maybe caused by an activated firewall"
    iam not sure if this is realy a problem because i can ping my notebook from the desktop pc and i can ping the desktop pc with the notebook, but i cannot see any shared files (not in smb:/ because of the above error message).

    It does not matter in which direction the filesharing works in the end (see a writeable directory on the windows pc from the notebook or an writeable directory on the notebook from the pc) but what do i have to do to share files?

    here is my: /etc/samba/smb.conf
    Code:
    # smb.conf is the main Samba configuration file. You find a full commented 
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the   
    # samba-doc package is installed.                                          
    # Date: 2009-09-30                                                         
    [global]                                                                   
    printcap name = cups                                                       
    cups options = raw                                                         
    map to guest = Bad User                                                    
    include = /etc/samba/dhcp.conf                                             
    logon path = \\%L\profiles\.msprofile                                      
    logon home = \\%L\%U\.9xprofile                                            
    logon drive = P:                                                           
    usershare allow guests = Yes                                               
    
    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S  
    browseable = No           
    read only = No            
    inherit acls = Yes        
    
    [profiles]
    comment = Network Profiles Service
    path = %H                         
    read only = No                    
    store dos attributes = Yes        
    create mask = 0600                
    directory mask = 0700             
    
    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    
    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
    
    [DOCUMENTS]
    path = /home/oliver/Documents
    guest ok = yes
    read only = no
    
    [FREIGABEN]
    path = /home/oliver/Freigaben/
    guest ok = yes
    read only = no

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: no working group: howto share files? (smb.conf included)

    Hi

    You've got several shares showing: [homes], [profiles], [users], [groups] and [printers]. You can read about them here:
    The Suse/openSUSE Default Shares
    The really useful one is [homes] which is a share of all the directories in your home folder (e.g. /home/john -- all the directories in "john"). You can access your shared home directories from vista like this in the network browser:
    Code:
    \\net_name_suse_machine\john
    You must add this line into the [global] stanza of smb.conf:
    Code:
    netbios name = net_name_suse_machine
    Of course, pick something useful for net_name_suse_machine.

    Regarding the firewall, it must be dealt with:
    First, turn it off in Yast --> Security & Users --> Firewall --> Disable firewall Automatic Starting + stop firewall now.
    Second: get sharing working between Suse & vista
    Third: Once networkis is good, turn the firewall back on and allow samba through the firewall using these instructions:
    Opening the Firewall for Samba
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: no working group: howto share files? (smb.conf included)

    Oh, I forgot this last thing about [global]. I suggest that you change this:
    Code:
    [global]                                                                   
    printcap name = cups                                                       
    cups options = raw                                                         
    map to guest = Bad User                                                    
    include = /etc/samba/dhcp.conf                                             
    logon path = \\%L\profiles\.msprofile                                      
    logon home = \\%L\%U\.9xprofile                                            
    logon drive = P:                                                           
    usershare allow guests = Yes
    to this:
    Code:
    [global]
    workgroup = NAME_OF_WORKGROUP
    netbios name = net_name_suse_machine
    name resolve order = bcast host lmhosts wins
    server string = ""
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    use client driver = yes
    map to guest = Bad User
    local master = yes
    preferred master = yes
    os level = 65
    usershare allow guests = Yes
    usershare max shares = 100
    usershare owner only = False
    Of course, this name NAME_OF_WORKGROUP you change to the workgroup name in the vista machine -- make them the same name.

    Finally check the Samba daemons are running, run these:
    Code:
    sudo /usr/sbin/rcnmb status
    sudo /usr/sbin/rcsmb status
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: no working group: howto share files? (smb.conf included)

    thank you for your help, i edited the smb.conf as you wrote. The check for the daemons resulted in: "unused" for both. Is this ok?
    But independent from that, i can now get access to the windows pc, but just when the firefall stays disabled. if i enable it, i get the "no workgroup found because of firewall" error.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: no working group: howto share files? (smb.conf included)

    The check for the daemons resulted in: "unused" for both. Is this ok?
    No it's not OK. Check the tutorial I linked in for how to turn them on in Yast in the section: Software RPMs and switching Samba on

    i can now get access to the windows pc, but just when the firefall stays disabled. if i enable it, i get the "no workgroup found because of firewall" error.
    Open the firewall for Samba as mentioned in my first post: Opening the Firewall for Samba
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: no working group: howto share files? (smb.conf included)

    ok everything is working great now, thank you for your help and patience.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: no working group: howto share files? (smb.conf included)

    Glad to be able to help. Enjoy.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •