Results 1 to 7 of 7

Thread: Missing many devel packages

  1. #1

    Default Missing many devel packages

    Hi,

    What are the devel repos I need to add?

    Are they
    Code:
    src-oss 
    
     Source RPMs. Advanced users only. 
      
    Version: 11.1
    Index of /source/distribution/11.1/repo/oss Src-non-oss Source RPMs. Advanced users only.
    Version: 11.1
    Index of /source/distribution/11.1/repo/non-oss
    11.1 repos don't add in 11.2, I got errors when importing the keys.
    I am missing some devel packages I need to compile cairo-dock but I can't find them anywhere. I try to rebuild the source rpm and rpmbuild gives me the following dependencies unmet:

    Code:
            dbus-glib-devel
            glitz-glx-devel
            libXcomposite-devel
            libXinerama-devel
            libXrender-devel
            libXtst-devel
            libXxf86vm-devel
            WebKit-gtk-devel
    I don't know where to look now, I googled, I checked suse repos and could not find how to get those packages. I have Packamn and many others on my list, including Factory and Contrib, Community, etc.

    tnx
    Frank
    openSUSE KDE 11.2 64-bits
    Intel Q6600 64-bits QuadCore G0 Revision
    nVidia Geforce 8600 GT
    ASUS P5K-E mobo + 4GB RAM

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Missing many devel packages

    Quote Originally Posted by Franksuse64
    Hi,

    What are the devel repos I need to add?

    Are they
    Code:
    --------------------
    SRC-OSS [/B]

    SOURCE RPMS. ADVANCED USERS ONLY.
    VERSION:
    *11.1*
    INDEX OF /SOURCE/DISTRIBUTION/11.1/REPO/OSS
    (\"HTTP://DOWNLOAD.OPENSUSE.ORG/SOURCE/DISTRIBUTION/11.1/REPO/OSS/\")
    * SRC-NON-OSS
    Source RPMs. Advanced users only.
    '
    ' (http://en.opensuse.org/Image:Susemini.png) Version:
    [B]11.1*
    'Index
    of /source/distribution/11.1/repo/non-oss' (http://download.opensuse.org/source/.../repo/non-oss/)
    -------------------- 11.1 repos don't add in 11.2, I got errors when
    importing the keys. I am missing some devel packages I need to compile
    cairo-dock but I can't find them anywhere. I try to rebuild the source
    rpm and rpmbuild gives me the following dependencies unmet:


    Code:
    --------------------
    dbus-glib-devel
    glitz-glx-devel
    libXcomposite-devel
    libXinerama-devel
    libXrender-devel
    libXtst-devel
    libXxf86vm-devel
    WebKit-gtk-devel

    --------------------
    I don't know where to look now, I googled, I checked suse repos and
    could not find how to get those packages. I have Packamn and many others
    on my list, including Factory and Contrib, Community, etc.

    tnx
    Hi
    You might want to use the search feature of zypper or YaST?
    eg
    Code:
    zypper se dbus*devel
    
    dbus-1-devel
    dbus-1-glib-devel
    dbus-1-python-devel
    dbus-1-qt3-devel
    It depends on what distro your coming from, glitz-glx-devel files are
    in glitz-devel, some of the others are in xorg-x11-devel.

    It also depends on the header files your looking for. I use;
    http://rpm.pbone.net/
    And use the advanced search feature to find any headers.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 RC 1 (i586) Kernel 2.6.31.3-1-desktop
    up 3:48, 2 users, load average: 0.27, 0.22, 0.21
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  3. #3

    Default Re: Missing many devel packages

    I come from 10.3, but all this is in 11.2 RC1 KDE4. Oh you mean the source rpm? That one comes from Fedora, it might not help.

    I do have the dbus-1-glib-devel, if it is same as dbus-glib-devel, it seems the rpmbuild doesn't see it that way, so I am stuck there for the moment.

    for example, I searched for '*xinerama*' but could not find one single package containing the word. That's why I think I am missing repos somewhere, or the xinerama files are in a totally different package and... oh wait, I think it's possible to search through (inside) the packages for libs, right?

    For example package 'abc123' could provide 'libxinerama-devel'. That I can do from Yast, I will try. Zypper certainly can as well, I've read it somewhere.

    The problem is when the package is named differently than what rpmbuild would list, I can hardly know easily.
    Frank
    openSUSE KDE 11.2 64-bits
    Intel Q6600 64-bits QuadCore G0 Revision
    nVidia Geforce 8600 GT
    ASUS P5K-E mobo + 4GB RAM

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Missing many devel packages

    Quote Originally Posted by Franksuse64
    I come from 10.3, but all this is in 11.2 RC1 KDE4. Oh you mean the
    source rpm? That one comes from Fedora, it might not help.

    I do have the dbus-1-glib-devel, if it is same as dbus-glib-devel, it
    seems the rpmbuild doesn't see it that way, so I am stuck there for the
    moment.

    for example, I searched for '*xinerama*' but could not find one single
    package containing the word. That's why I think I am missing repos
    somewhere, or the xinerama files are in a totally different package
    and... oh wait, I think it's possible to search through (inside) the
    packages for libs, right?

    For example package 'abc123' could provide 'libxinerama-devel'. That I
    can do from Yast, I will try. Zypper certainly can as well, I've read it
    somewhere.

    The problem is when the package is named differently than what rpmbuild
    would list, I can hardly know easily.
    Hi
    Yes if it comes from a different distro it won't work in most cases due
    to the differing package names....

    You need to unpack the src rpm, modify the spec file and rebuild the
    rpm.

    Why not use a proper rpm for openSUSE? If you ask packman they will
    probably update and put in the 11.2 repository, else download the src
    rpm for 11.1 and rebuild that.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 17 days 19:13, 3 users, load average: 0.17, 0.08, 0.06
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  5. #5

    Default Re: Missing many devel packages

    Ok I see, that's what I thought, if it's not opensuse it might cause problems. Learning...

    I think of asking Packman, yes, but I would not want to ask them every time cairo-dock releases a new version, it's a never ending story, that's why I wanted to compile it myself. I tried with the source tar but I end up with dependencies issues (only for plugin package) I cannot find, then I tried the fedora source rpm but I end up with different names on dependencies and it's as much complicated.

    I think best way is to ask Packman then. It was my next step after the source rpm.

    11.1 rpm has an older version, it's possible dependencies changed since. I know it did at some point, not sure between 2.0.7 and 2.1.0 it did, though.

    Let's try the Packman way.

    tnx!
    Frank
    openSUSE KDE 11.2 64-bits
    Intel Q6600 64-bits QuadCore G0 Revision
    nVidia Geforce 8600 GT
    ASUS P5K-E mobo + 4GB RAM

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Missing many devel packages

    Quote Originally Posted by Franksuse64
    Ok I see, that's what I thought, if it's not opensuse it might cause
    problems. Learning...

    I think of asking Packman, yes, but I would not want to ask them every
    time cairo-dock releases a new version, it's a never ending story,
    that's why I wanted to compile it myself. I tried with the source tar
    but I end up with dependencies issues (only for plugin package) I cannot
    find, then I tried the fedora source rpm but I end up with different
    names on dependencies and it's as much complicated.

    I think best way is to ask Packman then. It was my next step after the
    source rpm.

    11.1 rpm has an older version, it's possible dependencies changed
    since. I know it did at some point, not sure between 2.0.7 and 2.1.0 it
    did, though.

    Let's try the Packman way.

    tnx!
    Hi
    Generally when there is an update, packman will pick it up
    automatically and an update will appear. If you ask, I'm sure they will
    build the later version as well.

    You can always use the spec file (depending on issues) and just
    reference the later tarball in the spec file and it should build unless
    there are patches which may/may not require updating/deleting.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 17 days 19:56, 3 users, load average: 0.00, 0.23, 0.32
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  7. #7

    Default Re: Missing many devel packages

    For some reason Packman did not update since July. There has been 3-4 versions since.

    So I went the simple way and emailed them about it with web links providing the codes, as a reference.

    I guess I won't be able to compile it myself in the future, unless I manage to find out about the dependencies. Maybe throughout time I will, but if Packman can keep it fairly up to date, then no need for me to compile.

    tnx
    Frank
    openSUSE KDE 11.2 64-bits
    Intel Q6600 64-bits QuadCore G0 Revision
    nVidia Geforce 8600 GT
    ASUS P5K-E mobo + 4GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •