Results 1 to 3 of 3

Thread: GRUB Config Problem

  1. #1

    Default GRUB Config Problem

    This is yet another Windows/openSUSE dualboot problem thread. I'm about out of ideas, so need some outside assistance now.

    I have a mobo running nVidia nForce 4 Ultra chipset, so have several SATA drives on NV RAID as JBOD. WinXP and openSUSE each have their own dedicated drive, and I can boot each by itself via BIOS boot-order swapping. GRUB is on the openSUSE drive MBR. my current GRUB config files are as follows:

    device.map
    Code:
    (hd5)	/dev/disk/by-id/raid-nvidia_ehehddfb
    (hd3)	/dev/disk/by-id/ata-SAMSUNG_HD103SI_S1VSJ9CS617270
    (fd0)	/dev/fd0
    (hd1)	/dev/disk/by-id/raid-nvidia_efebaehb
    (hd2)	/dev/disk/by-id/ata-SAMSUNG_HD103SI_S1VSJ9CS617269
    (hd4)	/dev/disk/by-id/raid-nvidia_cfdgaeea
    (hd0)	/dev/disk/by-id/raid-nvidia_bhaecjif
    grub.conf
    Code:
    setup --stage2=/boot/grub/stage2 --force-lba (hd0) (hd0,0)
    quit
    menu.lst
    Code:
    # Modified by YaST2. Last modification on Mon Oct 26 17:32:35 PDT 2009
    default 1
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,0)/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Ec2 -- openSUSE 11.1 - 2.6.27.29-0.1
        root (hd0,0)
        kernel /vmlinuz-2.6.27.29-0.1-ec2 root=/dev/disk/by-id/raid-nvidia_bhaecjif-part3 resume=/dev/disk/by-id/raid-nvidia_bhaecjif-part2 splash=silent showopts vga=0x348
        initrd /initrd-2.6.27.29-0.1-ec2
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.7-9
        root (hd0,0)
        kernel /vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/raid-nvidia_bhaecjif-part3 resume=/dev/disk/by-id/raid-nvidia_bhaecjif-part2 splash=silent showopts vga=0x348
        initrd /initrd-2.6.27.7-9-default
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
        root (hd0,0)
        kernel /vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/raid-nvidia_bhaecjif-part3 showopts ide=nodma apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x348
        initrd /initrd-2.6.27.7-9-default
    
    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title Windows XP
        map (hd0) (hd1)
        map (hd1) (hd0)
        rootnoverify (hd0,0)
        makeactive
        chainloader (hd0,0)+1
    
    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
        rootnoverify (fd0)
        chainloader +1
    for the windows section, I have tried these settings:
    Code:
    title Windows XP #1
        map (hd0) (hd1)
        map (hd1) (hd0)
        rootnoverify (hd0,0)
        makeactive
        chainloader +1
    
    title Windows XP #2
        rootnoverify (hd1,0)
        map (hd0) (hd1)
        map (hd1) (hd0)
        makeactive
        chainloader +1
    
    title Windows XP #3
        map (hd0) (hd1)
        map (hd1) (hd0)
        rootnoverify (hd0,0)
        makeactive
        chainloader (hd1,0)+1
    
    title Windows XP #4
        map (hd0) (hd1)
        map (hd1) (hd0)
        rootnoverify (hd0,0)
        makeactive
        chainloader (hd0,0)+1
    Which gave me the following upon boot:
    #1, #4) Error 13
    #2, #3) NTLDR is missing

    Any suggestions are welcome.

  2. #2

    Default Re: GRUB Config Problem

    I think RAID support/repair and grub especially repair is buggy. Checkout the opensuse bugzilla reports on RAID.

    I have tried nearly every suggest grub/boot fix and needed to do a reinstall (on more than one occasion) to get it to work. 11.2RC1 may be better.
    HP ML110G5 E8400 2GB
    openSUSE 11.1, 11.2RC2 x86_64
    eVGA 8400GS PCI

  3. #3

    Default Re: GRUB Config Problem

    Thanks. I'll go look--I had a feeling that might be part of the problem. I have an 11.2RC1 DVD ready, but with the problems I started encountering I decided it might be prudent to eliminate the possibility of it being a beta problem. Well, it's not like installing takes long--and I've gotten really good at it recently.

    I also had another thought after a night to sleep on it. Perhaps I could use the XP boot menu instead of GRUB. Doing some Googling on that now. I fear the multi-drive setup will complicate things there as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •