Results 1 to 3 of 3

Thread: Rhythmbox Gstreamer Error ffmpeg

  1. #1

    Default Rhythmbox Gstreamer Error ffmpeg

    Hi guys,
    I have a problem with ffmpeg and opensuse 11.1
    I had to install again the OS; after installation of multimedia codecs (via opensuse community), I have this message trying to start rhythmbox:


    (rhythmbox:10454): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/gstreamer-0.10/libgstffmpeg.so: undefined symbol: gst_tag_setter_reset_tags

    (rhythmbox:10454): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: undefined symbol: gst_plugin_add_dependency_simple
    rhythmbox: symbol lookup error: /usr/lib/librhythmbox-core.so.0: undefined symbol: gtk_entry_set_icon_from_stock

    Can anyone help me, please?
    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Rhythmbox Gstreamer Error ffmpeg

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Rhythmbox Gstreamer Error ffmpeg

    Quote Originally Posted by matstardust View Post
    Hi guys,
    I have a problem with ffmpeg and opensuse 11.1
    I had to install again the OS; after installation of multimedia codecs (via opensuse community), I have this message trying to start rhythmbox:


    (rhythmbox:10454): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/gstreamer-0.10/libgstffmpeg.so: undefined symbol: gst_tag_setter_reset_tags

    (rhythmbox:10454): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: undefined symbol: gst_plugin_add_dependency_simple
    rhythmbox: symbol lookup error: /usr/lib/librhythmbox-core.so.0: undefined symbol: gtk_entry_set_icon_from_stock

    Can anyone help me, please?
    thanks
    You need libgstreamer-0_10-0 >= 10.0.22... the one from Packman.
    The problem is you mixed gstreamer packages of Packman with others from openSUSE.
    At really it's a bug, the package should explicitly require libgstreamer-0_10-0 >= 10.0.22. Report the problem to Packman... or even better, ask gstreamer developers to start using symbol versioning.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •