Results 1 to 7 of 7

Thread: problems setting syndaemon workaround in bashrc

  1. #1

    Question problems setting syndaemon workaround in bashrc

    Good afternoon,
    I'm almost finished installing this wonderful operating system on my Travelmate 7730. All works fine now, but I need this workaround for a "cursor jump" problem (caused by my Synaptic touchpad):
    DISPLAY=:0.0
    export DISPLAY
    syndaemon -t -d
    HOWEVER, setting this workaround in my .bashrc or .profile completely blocks the login procedure. The screen freezes and everything stops. I guess it is because the DISPLAY is set too early to :0.0 which confuses the X-server.
    How can I make sure the above script is executed at every login, without putting it in .bashrc or .profile. Is there another workaround to this?
    thanks.
    Emmanuel

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: problems setting syndaemon workaround in bashrc

    If I do a 'set | grep DISPLAY' I get DISPLAY=:0

    I think you should start finding out whether the synapctic driver (on which syndaemon operates) is loaded at all (su -c 'lsmod | grep synapt'). Most releases treat the touchpads as some kind of mouse equipment.
    Can you be more specific about the cursor jump?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,726

    Default Re: problems setting syndaemon workaround in bashrc

    Quote Originally Posted by Knurpht View Post
    If I do a 'set | grep DISPLAY' I get DISPLAY=:0
    Both :0 and :0.0 is correct (the second 0 being a default).

    I think when it is run (from where you have it now)it is one of two:
    . The X session is already running, in that case I suppose the DISPLAY variable is already in the environment and you do not need to define it again.
    . Or the X session is not running in which case no connection to :0.0 is possible (what you where already hinted a).

    Apart from Knurphts' observation that you may folllow the wrong path at all, what about putting it in the place where the things to start up for the DE are (different for KDE, Gnome, etc).
    Henk van Velden

  4. #4

    Default Re: problems setting syndaemon workaround in bashrc

    thanks for the feedback.

    I explained the cursor jump problem in detail in the following thread :
    keyboard problems ACER Travelmate 7730 with OpenSUSE 11.1 - openSUSE Forums

    doing su -c 'lsmod | grep synap' returns empty.... so that would mean the Synaptic driver is not loaded at all... but how can it be then that running the syndaemon -d -t solved the cursor jump problem?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: problems setting syndaemon workaround in bashrc

    That would have been on a previous version of openSUSE or previous Xorg or. ...
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Question Re: problems setting syndaemon workaround in bashrc

    Hi Knurpth,

    no that is with OpenSUSE 11.1 which I downloaded last week...

    I'm sorry, but I still don't see now how I can activate the syndaemon -t -d workaround now automatically. Since including it in .bashrc or .profile doens't work, how can I have it activated at each login, but after the X server has started up...?

    wbr

  7. #7
    Join Date
    Sep 2008
    Location
    Earl Shilton UK
    Posts
    298

    Default Re: problems setting syndaemon workaround in bashrc

    Hi, does this thread help you at all?

    Jumping cursor, - openSUSE Forums

    I suggested a fix that (which seems to work) at the top of page 3.

    It's the first time in ages I have looked at page 3 and found tips on how to use a computer. I need to get out more...
    Happily using Linux since 1998
    Share & Enjoy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •